Unable to pass Licence Page - Free Trial

Hello community,
I’m trying to use Lightburn on my MacBook Pro 2012. Installing went fine, but I’m unable to start the free trial on the License Page. When I click the button Start Your Free Trial I get a spinning wheel of death. Nothing happens and I need to force quit. I tried a few previous versions, with the same results.

I tried on my Mac mini (also 2012), and there everything works fine.

Any suggestions?
Thanks in advance!

What OS are you using on the pro? Do you have a firewall or anti-virus software that might be preventing it from using the internet?

OS: macOS Catalina (10.15.6). Tried with the (OS) firewall on and off, and I’m not using anti-virus software at the moment.

When it goes to the spinning wheel, try this:

  • Press Command + Space
  • Type ‘Activity Monitor’
  • Start that tool
  • Go to View > Run Spindump

Send the spin dump to support@lightburnsoftware.com so I can have a look. I can’t promise anything, but it might help track down what’s wrong.

We have the ability to do licensing offline, but we don’t have that for the trial at this time.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.