Undefined feed rate error -Smoothieware Setup

Hi all,

My machine was working a week ago but now I am getting error messages, the main issue being:
Error:Undefined feed rate
Entering Alarm/Halt state
Since my machine was working there has been an update to Lightburn but also Windows updates. I am wondering if anybody has had ths same issue & has figured out what the cause is & how to fix it?
I tried to set the feedrate with the “F” command but that didn’t help, please see attached for more specifics.

Can you tell me what you’re actually trying to do here? It doesn’t look as though you’re trying to run a job.

I moved the diode laser over to a position on the bed that I could have material under the laser head. My normal process is to do this and the fire the laser at low power and adjust the Z height of the laser above the material to get the focus close, the focus manually with the fine adjustment. Only after I manually focus the laser can I run the job. If I can’t fire it at low power I can’t focus it & I’m stuck before I start as it were.

Click the ‘Show all’ button on the console and post the text that it shows when you try to do this? The Smoothieware Fire command doesn’t need a feed rate (it’s not supposed to) so this is very strange.

Hi Oz,

As uploaded. I was playing about a bit more last night & noticed other strange things so have included these. The command is showing as being sent twice when I only typed it in once & I have no idea what’s going on with the ok - ignored part for the reset command?

The doubling is probably not the command being send twice, but one copy being sent directly to the console and another being sent from the gcode echo. I just wanted to make sure nothing else was being sent.

Try this: In the console, type:

Fire 10

And press enter. If you get the “undefined feed rate” error, it’s not a LightBurn issue, but a Smoothieware / configuration issue.

Then try this:


And repeat the above. I think it’s possible that Smoothie is just in a weird state, where it thinks it needs a feed rate value for some reason, but the Fire command doesn’t require one, so that makes no sense.

No change from that unfortunately.

The problem is the Fire command itself, apparently. Capital F is looking for a feed rate. Lower-case f will not, so:

fire 10

will work, but

Fire 10

will not.

How are you SENDING the fire command? LightBurn has a ‘Fire’ button that sends the correct command, and that’s what I assumed you were using here.

I have just tried that & you are quite correct, that’s crazy! :laughing:
Thank you so much for the help in finding me such a simple solution!

I think that’s how Smoothieware keeps their commands separate from GCode. All GCode in Smoothieware is upper-case letters, and their commands are lower-case. I know this, but it’s easy to forget. :slight_smile:

Thanks Oz, I will try to remember this as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.