Unrecognised board signature error after previously working fine

Hi,

I am running Lightburn 1.2.01, which is the latest version my licence will allow me to run. I recently swapped out the computer that I am running my lasers on, and since I had previously been using EZCAD2 to control my Fiber Laser, I gave the 30 day trial a go to see how Lightburn worked with it instead. Swapped the drivers, all was well, many good projects, no issues.

A few days ago, the trial ran out. No problem, happy to upgrade since it works so well, and I’ve now purchased the licence upgrade and confirmed it has applied. However, when I go to use the Galvo laser, I get “Unrecognized Board Signature” at the bottom of the screen, and I can’t control the laser at all.

I’ve seen there’s a few topics about this. I’ve tried:

  • Power cycling the laser
  • Removing the laser from lightburn and re-adding it (gets recognised in the list as a JCZFiber Unknown 110mm x 110mm)
  • Disabling antivirus
  • Restarting the computer
  • Updating Windows 10
  • Uninstalling and reinstalling Lightburn
  • Uninstalling the driver and reinstalling it, both through the Lightburn installer and the standalone driver installer
  • Using the ZADIG driver switching tool
  • Replacing the USB cable with a known good alternative
  • Swapping USB ports

When I revert to the old drivers and try EZCAD2, everything works fine in it on the same PC, zero issues controlling the laser.

I don’t suspect foul play with the licence, just bad timing. My suspicion is a Windows update, but they’re always going to happen. What should I do next?

I’ll put this link in, but I think you’ve gone done that road…

Don’t know if it’s sequence of what… a Windows update is kind of an issue… I understand the Windows Lightburn and EZCad drivers are not compatible…

Good luck…

:smile_cat:

Heya, thanks for the link. Unfortunately, as you suspected, I’ve already tried that and covered it in my list of “already attempted” dot points.

I’d love further suggestions from anyone, especially if it can help me perform further troubleshooting. Happy provide logs or anything else that can give insights too.

Small update on this one - I have a workaround, but not answers or a solution.

If I load an old project (from during the trial period), the laser works fine. No errors, full control, can run the project. From here, if I save a new copy of the file and replace the contents with new contents, I can use the new file for a new project.

However, if I try to create a brand new project from scratch, or I close and reopen Lightburn (so that it opens on a new project), then I get the error again. I’ve definitely got the laser selected in the dropdown list, and it’s definitely the same laser as the one I’m using in the existing projects.

This will help me accomplish my objective, but it isn’t going to help anyone else who comes across this issue in the future, nor does it explain why this is happening or how it can be fixed if suddenly my workaround stops working.

Does anyone have any thoughts or suggestions?

The trial software and the licensed versions are identical… The trial is used like a license.

Is the version of the trail package the same as the problem version?

:smile_cat:

Yep, I definitely didn’t change version when the trial ended. I just applied the Galvo upgrade to my existing licence and reinstated the licence in the software.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.