Unwanted Lines Keep Messing Engravings and Cuts

I’ve been using my laser for more than a year now but sometimes in this file i get sparse stray engravings and sometimes lines from one cut to another. I just can’t get my head around it!

I thought it might be stray EMF that triggers it (probably not)
Then i thought it might be a cable but it doesn’t happen in other files.
Could it be something with the fact that these notes are made with fonts? (i don’t know)
I tried emitting S value with every move (didn’t work)
I updated my firmware (nothing changed)
i rebooted my pc (nope)
i came back another day (…).

Laser:
Frame: Ortur Laser Master 2 Pro
Module: Ortur lu2-10a
[ORIGIN: China]
[PRODUCER: ORTUR]
[AUTHOR: ORTUR]
[MODEL: Ortur Laser Master 2 Pro S2]
[OLF: 191]
[OLH: OLM_ESP_PRO_V1.2]
[OLM:GENERAL]
[DATE:15:05:32 - Mar 13 2023]
[VER:1.1f(ESP32).20210403:]
[OPT:VNMZHSL,35,7680,3]

PC:
5900x
32GB RAM
Win11
Plenty storage

Rythmikos pinakas plywood 4mm.lbrn2 (161.1 KB)



$0=5.0
$1=100
$2=0
$3=6
$4=7
$5=7
$6=1
$10=2047
$11=0.050
$12=0.002
$13=0
$14=6
$15=0
$16=1
$17=4
$18=0
$19=0
$20=1
$21=1
$22=1
$23=7
$24=600.000
$25=3000.000
$26=100
$27=3.000
$28=0.100
$29=0.0
$30=1000.
$31=0.
$32=1
$33=1000.000
$34=0.000
$35=0.000
$36=100.000
$37=0
$39=1
$40=1
$41=0
$42=1
$43=1
$44=3
$45=0
$46=0
$56=1.000
$57=1800.000
$58=395.000
$59=6000.000
$60=0
$61=0
$62=0
$63=3
$64=1
$65=0
$100=80.000
$101=80.000
$102=2124.000
$110=10200.000
$111=10200.000
$112=600.000
$120=2200.000
$121=1800.000
$122=200.000
$130=400.000
$131=410.000
$132=100.000
$259=0
$260=70
$261=0
$262=400
$263=0
$264=0
$265=50
$266=100
$267=0
$268=0
$269=0
$270=5120

I read all the relevant posts i could find but i just can’t find a solution, please help me.

Help please? @LightBurn

I’m not seeing what you’re seeing, because I don’t know quite what to look for.

Can you highlight exactly what’s wrong in a couple of detailed closeups?

Reuploading with circles around the extra lines and engravings.


Now that I see what you’re pointing out, I think you’ve pinned it down: the font has glitches. This seems not uncommon with specialty fonts; it’s apparently quite easy to produce font glyphs with problems that only appear when they’re used in non-print applications.

Perhaps creating the layout in a graphics program (or whatever you’d normally use), exporting / printing it as a PDF or PNG, importing that file into LightBurn, and treating the whole thing as a single graphic will produce better results, because the glyph rendering occurs in a program intended for that purpose.

1 Like

Thank you sir, I will try it out again with a pdf file or convert it to paths through Inkscape. I forgot all about that option…
I will report back my results!

You can convert to path inside LB, for what it’s worth. I do it often.

Do these stray lines show up in the preview if you zoom way in?

I thought about converting the fonts into paths through lightburn but I didn’t want to risk having the same problem again if it’s a problem of lightburn not being able to read the fonts correctly.
As for the preview, no these lines do not appear in it. And that makes me wonder if the problem will be solved simply by converting the fonts into paths or not.
I will have to test it in the next few days.

Curious. I’ll be interested in seeing if the path conversion reveals or fixes anything.

@NiX I’m on a plane just leaving LBx when I read your post. If you’re interested and willing to share the file here (privately or publicly) I’d be happy to take a look. I may also need your font file to attempt to replicate the behavior you’re seeing.

@JohnJohn Hi there, i’ve already uploded the Lightburn file in the 1st post.
I’ll share here the fonts. I used WeTransfer as the forum doesn’t allow font files to be uploaded straight here.

Thanks in advance for your time, i appreciate it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.