Update to 0.9.18 causing communication issue

Since update from 0.9.16 I have not been able to communicate with machine , worked perfectly before and if I revert its working …
Now I get this response and am unable to fire or move the laser
Anyone have any ideas?

Continuous Jog works on 0.9.16 and I have tried turning it off , it made no difference

ATMega 2560
Ramps 1.4
grbl MEGA 5X firmware

  • Do you have other COM ports that you could choose?
  • Is there any other software running that might have the COM port open?

Go to Help > Enable Debug Logging
Then click ‘Devices’, and ‘Ok’, wait for it to try connecting, check to see if you have other COM ports available, and then quit.

You’ll find a file called ‘LightBurnLog.txt’ in your Documents folder. Attach that here and I can have a look. Nothing in that release should be preventing a device from being found.

Hi, I have other free COM ports I could change to in Device Manager
there is no other software running that wasn’t running when 0.9.16 was working…

Here is the log , I hope it shows something useful , cheers

LightBurnLog.txt (7.6 KB)

It displays the ready status and can find the machine , it just wont communicate …

It looks like that version of GRBL isn’t behaving the way it’s supposed to - The port is found and opened successfully, but the controller isn’t answering with ‘ok’ when I send the equivalent of pressing the ‘Enter’ key. This is how LightBurn knows it’s there and it’s safe to start talking to it.

I used to send G0 as a command, because it’s harmless, but if the controller was still initializing, that would cause the controller to report an error, because it wasn’t ready to process “real” commands yet, and a number of our vendors complained about users being confused by that error.

So, it makes perfect sense that fixing it has broken your setup, because that’s how all bug fixes actually work. :slight_smile:

I’ll look at adding an option to the config to let you choose the initial ‘hello?’ command. I really wish the folks porting GRBL would stop changing random stuff. One decided that for his port of GRBL, the dwell command should be in seconds instead of milliseconds.

Don’t know if its relevant but when I quit Lightburn I can hear the motors “release” after a few seconds.
Do I need to try to find updated firmware ? Is there a work around or do I need to revert 0.9.16 until I find firmware ? cheers for your help

I don’t have a setting or anything to change that behavior, so you’re stuck with 9.16 until I can change the startup cycle.

Ok , no problem , I’ll revert back for now , thanks for looking into it , cheers mate

I’ve logged this as a bug, and included a link to this thread, so I can reply again when I fix it.

I have a Universal Engraver which is a GRBL machine. Ever since the update to 0.9.18 and 0.9.19 it won’t connect. I’ve reverted the software and verified that on lower versions of Lightburn it connects and burns as intended. I’m trying to figure out if this issue posted here would be related to whatever would cause the program not to recognize my laser.

What do you see in the console window in LightBurn? Have you chosen a COM port?

Hi, yes I choose a COM Port and the Laser window updates to say “Ready” after about 3 seconds, but the Console section continues to show “Waiting for connection…”. No matter how long I wait, or how many times I disconnect and reconnect my USB cord from the laser to the laptop, or how many times I try reselecting the device from the Devices drop-down, it never shows the typical verbiage about it connecting and “Ok”. I have tried the update twice, and each time the only thing that resolves it is reverting to version 0.9.16.

I clicked the link you provided and it says, “As long as your laser is connected to the same communication port, LightBurn will reconnect when you re-start. If you reboot your computer, or plug the controller into a different USB port, you might need to re-select it.” This hasn’t been working for me for several months though. What I mean is that I can be connected and using the laser, finish my job, close Lightburn and leave everything plugged in exactly how it was, open Lightburn back up just a few minutes later, and the Console section is stuck on “Waiting for connection” even though the Devices section shows the correct device and COM Port. I have to manually cause it to connect by right-clicking the Devices button, or selecting “(Choose)” in the COM Port drop-down and then re-selecting the COM Port that was already showing when I started Lightburn up.

I’m only sharing this additional issue in case it helps pinpoint what might have changed to cause the communication issue with later versions.

In 0.9.19, go to Help > Enable Debug Logging, then right-click the ‘Devices’ button to re-attempt the connection. Count to 5, then quit. You’ll find a file called ‘LightBurnLog.txt’ in your Documents folder. Attach that file here so I can see what’s happening.

Thanks so much for your help. Here’s the Debug Log.LightBurnLog.txt (6.3 KB)

I’m having the same connection problem. worked fine before update.LightBurnLog.txt (9.2 KB)

for what its worth…
on my setup if i open lightburn and it says waiting for connection…
if i change com port to “choose” then open pronteface and connect to my laser…
connection successful…
then disconnect and close pronterface then back to lightburn, still open… choose correct com port… then lightburn connects…

just throwing that out there. hope it helps. lol
thank you

LightBurn is sending the equivalent of pressing enter to the controller, and waiting for it to reply with ‘ok’ so it knows it’s there, and it’s not doing that. I haven’t been able to figure out why.

Can you check in Edit > Device Settings for the ‘Enable DTR signal’ toggle - try it both on and off and see if one works?

Sorry for the delay.
I toggled enable dtr and it was the same either way. "Waiting for connection"restarted lightburn between each setting change.

Also idk if it’s related but with enable dtr “on” the connecting with pronterface first then lightburn doesn’t work. But with dtr off lightburn will connect after a connection with pronterface. This doesn’t work with ugs or lasergrbl… for what it’s worth… above my pay. Lol

Can I ask both of you to try this version?