Updated to win10 20H2 yesterday, Lightburn Import locks up

Lightburn is V0.9.18 (Ruida controller), since updating win10 to 20H2 yesterday, see below

I cannot import anything using the File/Import method. The Import screen opens, but locks up when I click on anything. Taskmanager shows LBFileDialog.exe(2) has high CPU usage. Clicking the X button gives . Closing this task in taskmanager clears it but Lightburn is locked up and unresponsive. All other File functions seem OK, is this an issue between this version of Win10 and LBFileDialog?

I can import files by copying from explorer and pasting, or dragging from Explorer, and Lightburn is OK.

Regards Graham

I’ve had other people report this, and have never been able to reproduce it. If you don’t mind, can I email you a test build to try?

Edit: scratch that, try just downloading 0.9.19, posted today, to see if that resolves it. I made a very small change to the LBFileDialog, but it’s one of the only places I can see that could have the potential to cause what you’re seeing.

Thanks Oz. I just tried importing in 9.18 on my laptop (yesterday was busy with grandkids) and it worked ok on the laptop, also runniing win 10 20H2. I have installed 9.19 on my laptop and is ok. Will install 9.19 on my main PC shortly and get back to you then.

Ok Oz, here’s where it gets weird. Yesterday I couldn’t import on my main PC using 9.18. Before I updated to 9.19, I tried importing and it worked OK. I had restarted my PC a couple of times yesterday with no success, today all ok. I have updated LB to 9.19 and it works OK too. Thanks for the very fast response and fix.
Rgds

Graham