Usb com 7 always dropping randomly

I know this is old as heck.I am using a OLM3 Pro and I just keep dropping communication in my usb 7. I have searched,downloaded, upgraded,added power hub and this is just getting worse by the day. I am in a big job and this wasting material. I have seen so many topics on this and still see no apparent fixes. Please anyone have any suggestions. I am running a Dell PC and recently started getting worse.

Thanks

Danny

Nearly every topic on a communication issue I read ended in a solution, and I think I have read a lot of topics. What we need is more info from you.

  1. Have you tried a new USB cable?
  2. Is your USB cable longer than 10 feet?
  3. Have you disabled the USB energy saver mode in Windows?
  4. Does your USB cable have a ferrite on it?
  5. Has the Laser window offered any other Com ports other than Com7?
  6. Have you tried to connect to the S9 with any other software, like LaserGRBL?

I know communications issues can be exasperating, but they can be solved with persistence. Run thru the above list and let us know the results. Feel free to question any step that may sound confusing.

1 Like

Yes to all the above other than LaseGRBL. It started with the cable with the ferrite so i purchased another USB. It worked after the first two engravings failed. I just kept starting over and finally the next three worked with no disconnect. This is so random and makes me gun shy to start my projects. My S9 has been fine for a while but it has occurred with that one as well.I did change my default port to Comm 2 instead of 7 but that didn’t seem to fix it. It seems like something is sending a signal and killing the connection. Thanks

Sorry I did not get back to this before now.

It sounds like you might have RFI (radio frequency interference) from an outside source. You do not indicate your location, industrial or home…
Industrial = Any new equipment installations. any old equipment that has contactors cycling on and off, Nearby power pole transformer arcing. Poor grounding of the laser or surrounding equipment.
Home = Poor grounding of the laser. Washing machine or A/C unit cycling on or off. Amateur radio (look for new outdoor antenna nearby, either a tower or long wire [which will be hard to spot]).

Try to correlate the failure with a sound or strange noise, change in air flow or temperature, blinking lights, time of day, etc. From what you describe, you will have to do some serious sleuthing to find a source and solution. Keep notes of what you do and do not find.

Sorry I am getting back but I had a broken antenna and had a new one but i just got around to replacing and there hasn’t been an issue since.ight not have been the problem but that and a reinstall of the firmware and all has been fine for a few weeks.Knock on wood as they say. LOL

Glad you are back in business!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.