USB disconnected while trying to update firmware

I get connected to the Ortur Laser Master 2 Pro via USB, and try to update the firmware, but as soon as I try to paste the BIN file into the “drive” for the laser, it gives an error about the device not being available. The USB is automagically diconnecting. When initially testing, I also noticed that it pauses before a simple FRAME command can be completed. Any ideas?

What specific series of the 2 Pro do you have? What’s your current firmware version?

Have you followed the instructions from Ortur exactly? What computer are you using to perform the upgrade?

Please attach a screenshot of the desktop and the error you’re seeing.

Thanks for the quick response! I think I found a solution. “Get a different laptop.” I had been using an old Lenovo Yoga laptop and wondered if it was the problem. So, I set up an old ThinkPad laptop and it actually worked! I have now got the firmware updated and the frame command and a simple burn worked as expected!
So, I am sorry to have wasted your time, but your “what computer are you using” question reminded me to try that.
Thanks for your help and stay safe!

want to hear a story?

I only run Linux and Ortur said only to update using Windows. A bunch of Mac users bricked their Ortur trying to use their Mac. I’ve got some hardware balls so I looked and noticed it was an STM32 controller and I can program the chip directly. Fought and finally Ortur shared with me their bootloader firmware. I burned it and now I had to figure out WHY DO I MUST USE WINDOWS… spun up a Windows 98 virtual machine and sure enough the firmware uploaded. FAT32 filesystem issues? Sure as heck. I used the Linux based mtools version of mcopy(mcopy -D M -D m OLF_000.BIN /media/myUser/ORTUR\ LASER/) and it worked. Their bootloader looks for the hidden FAT32 filename and that is all that stopping other OS’s from updating the firmware.


Are you able to use the laser on the original computer? Or only the computer that you used to do the firmware upgrade?

Happened to me as well, running Manjaro GNU/Linux, didn’t have energy to spawn a VM.
Finally I have used an OTG cable with my Asus ROG2 phone running LineageOS.
Connected the machine in upgrade mode and copied the BIN file, it worked.
Just my 2C