Using: Light burn, Jtech laser driver , Open builds controller problems

Afternoon all, I am using the Jtech 2.8 laser with the driver, light burn program and Open Builds controller as used on the “Acro” laser package. My problem is there seems to maybe a conflict. When I start to do a burn project , I usually first start the laser driver then the Light Burn program , then the open Builds controller which drives the stepper motors. I have a problem when I start in this order and I cannot jog to position the laser. Com port is shown. Some times there is no connection, also jogging directions are reversed. I have tried a lot of different starting variations of what program to start first and its a hit and miss. What sequence / order have you been using that works and if any settings I need to look at? I have opened up Openbuilds controller and reversed / inverted the jogging direction there then opened light burn with the correct direction. Wondering is there a better way of saving this without opening Openbuilds Controller and changing it there?
Thanks, AL

Power the controller first, then right LightBurn, and it should connect pretty much right away.

When you say you’re opening ‘Open Builds Controller’ - is that a software application to talk to the machine? If so, you don’t need it, and it’s likely conflicting with LightBurn.

Thanks Oz,
I did turn on the Jtech driver first then the Light Burn program and was not able to jog.
So , I turned on the "Black Box " so I could have power to the stepper motors…and was now able to job ok…
When I say open up the Open Builds controller , it let you set the direction of the stepper motors if your axis are going the wrong direction as well as the grbl settings for a cnc machine. The Black Box is the motion control system.
I was also thinking that the black box was conflicting also but then how do you control the stepper motors? The Jtech laser driver is just a driver for the laser…
Thanks, Al

The BlackBox is the controller that LightBurn talks to. If you open another piece of software that talks to the machine, that will conflict with LightBurn - only one can talk to the machine at a time.

The OpenBuilds control software is likely just setting GRBL settings to change motor directions, though I couldn’t say for certain. The BlackBox controller runs GRBL, and GRBL has its own settings for motor directions. You can change those settings in LightBurn too, using Edit > Machine Settings.

I don’t see a menu for “X, Y, Z” settings to reverse or invert…
Thanks

You don’t have this section in your machine settings?