V. 1.3.00 Bug (Frame slop)

I installed latest version. I am using CNC, w/Ruida controller. I am getting error message “Frame Slop” that is preventing me from cutting on my machine. I know ya’ll posted about some issues - has this been resolved? I have even reverted to previous, older version and am getting same issue (that was an issue before). Any workaround you can offer?

From our “Trouble Shooting Ruida” section of our docs,

Frame slop over

  • The design itself is crossing one or more of the machine sides. You can continue, but the controller will not draw the part of the design that is out of bounds.

That is strange because my workspace is 62" x 36", and cut was only 48" wide - and i even centered it on the bed to allow for spacing on each side of the gantry arm running back and forth (well within the bounds of the dimensions for the cut). I had to make adjustments to the dimensions to proceed. Thank you for being super responsive. :grin:

The Ruida applies the ‘overscan’ via hardware so it’s dependent on your speed setting. I’ve never seen the Ruida to be wrong here…

Do you have the ‘start from’ and ‘job origin’ set correctly?


tl;dr: Slow Down

As @jkwilborn identifies, the speed the head is traveling as it sweeps back and forth is a major factor in the calculation that would trigger this ‘Frame slop over’ message. Just like with driving a bike or car, the faster you go, the longer it takes to slow for a turn.

As you increase the layer job / processing speed, your Ruida control system adjusts the amount of further movement required to change direction. If you adjust the speed downward a little and check again, at some point you will find a speed for producing this layer without the Frame slop message. Often, it is the size or placement of the job within the laser. Yet, many more times this message is related to the speed you are asking the system to travel, and it simply can’t change direction in the room given. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.