V1.2.03 doing line before fill

In older versions we had the “fill+line” option on a layer, that has been replaced with the multi mode giving us sub layers so we can have sub1 = fill, sub2 = line to accomplish the same task. As of v1.2.03 Lightburn is running the line layer before the fill, no matter which order the sub layers are in. I reverted back to v1.2.01, opened the same file (ignored the version error message) and get the expected behavior, fill then line.

For info I am not experiencing this behaviour, it performs as it should.
In the preview at least, I haven’t checked it whilst running

I see it in the preview on v1.2.03 as well as the burn, but not in v1.2.01 with no changes other than reinstalling the older version. I tired shifting around the optimization settings, but that had no impact. Fortunately the older version works fine for me so I don’t have an urgent need for a fix, but it is very odd.

I also noticed similar behavior reported in V1.2.03 and Material Test
The text I had was in a circle, it would do seemingly random letters instead of doing a full circle, still line then fill.

Can you post the .lbrn file you are referring to ?
Just to see what is happening.

Test - burn order.lbrn2 (71.1 KB)

Sure, here’s a test file that reproduces the behavior. I also have some new information.

  1. it doesn’t happen with new files created with v1.2.03
  2. it happens with files created with v1.2.01 and opened with v1.2.03
  3. when it does happen in v1.2.03 if I move the frame layer from the top the to bottom it no longer does the line before fill.

Thanks John, that is strange, moving the tool layer to the bottom as you say makes the cut as expected. Good spot.

One for the Lightburn folks.

This is happening to me too. No matter what optimization settings I use, whether I group a shape with a line and fill, or what order I have the layers listed, the line wants to cut before the fill which doesn’t work for me because the material shifts when cut. I am on 1.2.03 connected as Ruida 644XG 60w. Previous versions this would happen from time to time but generally grouping or ungrouping would work.

This was a known bug in 1.2.03. Should be fixed in 1.2.04 as outline here:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.