V1.2 Rotary doesn't return to Origin post burn?

Noticed this post upgrade to version 1.2.00

Usually after the rotary burn completes, it returns to Origin.
However, now it is returning to an unknown X position that lines up with Y, but is about 350 to 400mm far right of Origin.

Post burn if I hit start again to burn the next layer, it does know the origin and is right on, however, takes it awhile for it to return to the burn area, since it went so far right.

Is there a new setting that v 1.2 is using that I might be missing ?

btw, I have homing X and Y disabled on my Rotary import file.

There is a setting within the Ruida that specifies where the ‘return’ is.

Screenshot from 2022-07-15 13-44-52

Might check that…

:smile_cat:

Indeed, thanks.

So I edited in Notepad++ and looked at my Rotary backup files that I exported, all show return to Absolute Origin.

Odd that for 2 years it has always gone back to Origin when done, and every single time that I switch from honeycomb to Rotary I import and write these backups.

So when in Rotary mode, what is definition of Absolute Origin?
Where the head was when I turned the laser on, since I have homing X and Y off ?

Thanks

Since you’ve turn homing off, it’s where ever the head is at power on. Origin is stored in the controllers memory.

If you set the ‘origin’ after you setup everything, it may return, but it has no way to determine where it is if it can’t home.

The best way to change the configuration is to use the gui at "edit → Machine settings’. You can write, read, load and store the configuration from there.

Glad it’s up again. If this solved it, please mark the thread accordingly.

Good luck

:smile_cat:

so maybe a feature request would be nice on the Laser Tab below the
Start From drop down (Curr position, User Origin, Absolute Coord)
Add another drop down - End At ? with same 3 options.

It confused you, you want to make it more complicated… lol


If you get used to the machine coordinate system this will cover all bases.


In your case, if you had this option, where would you have it “End At”?

You cannot enter any kind of ‘known’ coordinate as the machine has never homed… so it’s all relative to where you put the head when you power it up…

:smile_cat:

Yes, there is a known coordinate, User Origin.
Would be easier to pick that from Drop down, then to have to hack settings via Machine Settings.

Origin is already there… That is user origin. The others are ‘none’ and ‘absolute origin’ (0, 0).

Didn’t think many bothered to change it doing various jobs. I leave mine set to origin.

Good luck

:smile_cat:

I’m talking about Post Burn
Have a drop down for Return To

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.