Variable Text Advancement Not working

I am using variable text to read from a list of names and data from a csv file. I am printing out 2-5 items with different names. So my first job is using row 0 and row 1 information to print the first two items. So I want to through the list of names manually just creating my job, and then sending that print job to the printer. I don’t need to use the auto advance and just want to move the number manually without next/prev buttons.
Right now, I have printed the first two, worked great! And I now want to now print the the next 3 rows from the csv file.

I have auto advance off. I have moved Current =2, start = 2, end = 73, advance=2.
I have also selected the first three items on the my work screen.(I can hold 5 items on my bed and I have 5 items in my “template image”). So if I “press” test on the variable text it updates the window with the correct names. However, if I do a print preview, the preview reverts back to starting at the first item in the list.

Sometimes if I hit next-previous it advances correctly on the test image, but not the preview. Sometimes the test image does not match the rows I am on.

Other thing I found. If I do press “test” button and it shows correct, and then I switch off the variable text tab, to the move tab, and then back. The “test” button also reverts back to the first row now.

I am running 9.0.7

To keep going I am just going to remove the first two items from the csv file and keep going so I am not blocked.

There is a bug in the current release with CSV files. This has been fixed already, along with a few other enhancements, like better CSV parsing, support for quoted strings containing commas, and Mac formatted files.

I will give it a try.

It’s looking like everything is fixed that I have tried. Thanks!!!:grinning::grinning:

Everything I have tried for the last two days is working great. From updating the image from %0 to the actual value when preview or send is sent to, next/prev, starting, current. Everything I have tested is working great. On my second data set from yesterday. Thanks for the fix.


Happy to hear it. :slight_smile:

I’m having the exact same problem - says my software is up to date – any thoughts?

The changes Kenneth got are being released in the pending update which is why you don’t have them (he was willing to be a guinea pig). We’re planning to release in a day or two.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.