Vers 0.9.17 Laser Fire button overridden

Just upgraded to 9.17 and love the improvements but there is a little change I dont like.
I use the fire button to have a low level laser on while I line up material etc then I move the laser around to check the material is square on etc. However now in V9.17 the laser switches off after every move regardless of the fact that the fire button stays lit (as it should). Can we have it back to staying on until we switch it off or until the Start button is pressed please?

Im using a Mac in this instance

1 Like

enable fire button

He already has the fire button enabled.

Yes thanks Nick.

Bertus, I do know how to use this, had it for ages.
The change in 9.17 is that the laser turns off after the next action while leaving the fire button lit. I want the laser to be on when the fire button is lit and off when it’s not. And I don’t want moving the laser to switch it on and off.

What I use this for is to align the laser on a cross on the material to be cut. I nudge the laser til it its the cross then start burning from that position. But now every nudge I need to hit the fire button twice, oce to turn the button off and again to run the laser on again and nudge an d repeat. That can be 30 or 40 presses where before I had one. Bad show! Im going back to the old version!

Hold the Shift key while jogging to keep the beam enabled - does that not work? There was a change made to the way the jog commands are sent to the laser, and it’s possible that change is what’s turning off the beam (it’s a program-end command, M2, at the end of each jog)

I have same problem with 9.17.
weak laser is on but if I move laser to right 200 mm, laser is on when it move, but after stop it shut down.

The problem has been found and fixed already - we’ll be releasing a patch fix shortly.


Thank you Oz.
My shift key is just out of reach when I’m jogging the machine :grin:

Great! Thanks Oz!

The 0.9.18 release just posted fixes this.


Hi Yes 9.18 fixes this but jog is limited to one command at a time now? Used to be able to jog a few and it would catch up, but now I have o wait for each move to complete before I can key the next one. Is that intentional? It’s much slower to line up material etc.

It is intentional, yes. Jog commands are based on where you are right now, and if you clicked multiples in the past they would sometimes do weird partial moves based on where the laser was when you clicked the button instead of where it was when it finished the current move.

If you enable continuous jogging it’s easier to do what you’re saying, or use the ‘Click to position’ button in LightBurn.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.