Version 1.0.04 Message Not Seen In Earlier Versions

When starting a cut, I’m getting a message that some elements are outside the work area and will not be included. Clicking OK starts the cut. I believe this is happening because I keep a T1 frame larger than my working area in my projects to indicate the table size (in my case 12" x 12"). I always use this frame to help position cardstock for cutting. Did not get this prompt in any version before 1.0.04 though. Perhaps I should just revert back to 1.0.03 but then I might never be able to update the version without the problem re-occurring.

You can test this and will still be able to continue to update to a newer version as long as your license allows. You can post the file and we can review. :slight_smile:

1 Like

I opened a project with the T1 frame then deleted the frame before starting the cut; the “out of bounds” message did not appear. Will downgrade to 1.0.03 and then retry before posting a file.

Downgraded to 1.0.03 and the “out-of-bounds”
message did not appear; the cut started as expected.

Sexy Witch 2 - 8 x 10.lbrn2 (52.2 KB)

I will take a look. I did a simple test with our latest beta (1.0.05) without issue.

Edit: Loading your file and then hit ‘Preview’, I do not get any warning of ‘Out of Bounds’ reported.

Loaded 1.0.04 again and opened file I sent. Still get the OOB message when I select Preview. Attached jpeg but it’s not too good.

The attached image is useless and unreadable. Please take a screenshot of just the full LightBurn screen and post that so we can “see” what you do. :slight_smile:

Sorry - this should be better.

I do notice you have a mark, far to the left of the workspace, but that is also on the Tools Layer and should not trigger this warning.

I am digging in further…

Hi Rick, would it be anything to do with T2?
I was checking out the project to see if i could find anything, i selected all but T2 wouldn’t select and could only delete it from the layer pane.

@Kris1, I am investigating this issue further. The T2 text and rectangle are ‘Locked’, signified by the bounding marks. Unlock from ‘Shape Properties’ tab or via right-click menu with these objects selected.


Thank you sir for your attention! I suspect I’m not the only person affected. This isn’t a show stopper, just an annoyance. It’s curious I didn’t experience this before 1.0.04. I started with v0.9.24 so have used 5 versions without having this crop up. The only problem I see with going back to a previous version is that you can get warning messages when saving after downgrading if the file was created in a newer version. I don’t see that anything actually gets corrupted though. This is a fantastic program BTW.

1 Like

Thanks Rick, something i’ve never used. :slightly_smiling_face: :+1:

1 Like

I locked both the T1 and T2 objects so I wouldn’t accidently move them while designing/editing. I wouldn’t think this could cause the problem but can test by unlocking them and report back.

I wasn’t aware that there was a line to the left of the workspace on the Tools layer in this file but found it. I have the same OOB result using many different files; not just his one.

BTW - using a Dell Studio laptop, Win 10 64 bit with latest MS updates, Woodpeckers GRBL 1.1f controller driving an Oxlasers 5.5 watt diode laser on a modified Creality CR10s frame. Haven’t made the plunge to CO2 laser yet but probably will.

@GPLewis are you using user origin or absolute coords? In @Rick 's example he is using absolute and not running into issues. When I setup a GRBL device in 1.0.04 and set it to absolute with framing turned off on the tool layers I have no issues with the out of bounds message.

It makes me wonder if you have your origin set to center or on of the other radio buttons that isnt the zero point of the machine and the image doesnt quite fit in in your bed even though its placed in the bed area in lightburn.

I use Absolute Positioning and have the origin set to front/left - that said, I had Frame turned on in the Cuts/Tools dialog for both T1 and T2 - I turned Frame off for both and the warning goes away! Thanks Joe for pointing me in the right direction to solve this. Still a little curious why this didn’t occur in previous versions but at least I can get around the warning dialog. Thanks Again!!

We will look into it. That warning is consistent across all the systems I have here for 1.0.04 so thank you for pointing it out.

1 Like

So it didn’t happen in previous versions because you weren’t able to frame tool layers then. This was a feature that was recently added and is working as intended upon further discussion.