Version 1.5.02 crashes when trying to apply path to text with SHX font

Hi, I’m trying to apply a path to text written in an SHX font and Lightburn v 1.5.02 is crashing. It works fine with a TT font. I’ve never tried this with an SHX font before, so I don’t know if it’s an SHX font thing or a version thing. I’ve tried with a couple different SHX fonts, same result. Has anyone done this successfully? Thanks!

Carrie would you be so kind to save you LBRN before applying the path to text so we can try to replicate?

… Was trying but cant Replicate with my fonts

Could it be a combo of your path and your font?
could you list the font used please?

Well, apparently all I had to do was tell the doctor about the problem, and now it’s working fine. Super weird! I repeated the issue 3x before posting, maybe my computer was just using RAM for something else and not having it.

What happened after I posted:

  • I went ahead and cut the file using an outline of a TT font
  • Then I copied the geometry, pasted, and changed the already-on-a-path TT font to an SHX font and it worked.
  • Then I tried copying the geometry, pasting, deleting the text on the path, created new text, applied it to the path, and it was fine.

So yeah, working totally fine now. Thanks for the quick reply, though! I was using the Stencil SHX, and also one of the DIN SHX fonts. Still using Stencil when it just worked.

1 Like

If i had a dollar!

Glad is working!

1 Like

Ah! I think I know what happened. I had just installed Lightburn on a new computer and just selected the SHX font path. That path is on a drive in the cloud, so it was probably still trying to access the path and finalize the font downloads in the background, while I was trying to do the text to path. The fonts displayed fine in a normal text object, so it’s still a little mysterious.

Interesting.
Should be replicable

@Rick @JohnJohn
Something that is worth report?
Unsure if CTD is acceptable behaviour

Cloud storage offers all kinds of interesting file system problems like data loss and file damage. It’s not present in every case, so it doesn’t happen to everyone all the time. Generally, we advise folks to avoid Cloud storage, Microsoft OneDrive, Dropbox, etc. Removable storage, like USB drives, has also presented similarly unpredictable behavior so we advise against that as well.

It’s always worth reporting. Thank you for the heads up.

Good to know. I haven’t had any issues with the cloud file storage in the past, but also realized that on our old computer, we had been syncing the folder with all Lightburn files and SHX fonts locally, so I went ahead and did that again. (We’re using Box.)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.