Very odd behaviour

Ok, so I’ve not used my machine much since Christmas. RDC6442G controller 40W A3 CO2 setup, Lightburn v0.8.07 64bit Win 10.

Last week I did a small job (a couple of acrylic dog tags). Simple scan+cut 200mm/s @ 15% power, followed by a cut of 12mm/s @ 65% power.

Initially unable to cut directly from LB ( Sorry don’t remember exact error ) so sent file instead (via usb). Job completed so didn’t worry too much… Today I modified the text in the LB file and sent direct to laser. Cut+scan completes with no problem, but the cut only simply marked the surface! (3mm cast acrylic).
Tried a few times, in between rebooting laser, no change.
Looking at the ammeter, the tube was bearly drawing 2mA, compared to around 18 mA. At this point I’m thinking dying tube or psu, but it’s only seen about 500 hrs use and NEVER exceeded 18 mA (tube is rated @ 23 mA).
Next check is the pulse button. Cuts through without problem.
Drew a small rectangle with LB and tried to cut again directly using usb. It started to cut, but failed on the third side with a beep from the controller and an error, “file invalid” on the display (LB had reported that file had been sent). Looking at the test piece, it also hadn’t cut through.
Lightbulb moment, try RD Works… Connected using usb once more, small rectangle, same cut parameters, hey Presto, tube and psu are ok after all!

So I’m now wondering if my LB has somehow been corrupted, or a change in the latest version has introduced a bug. I uninstalled and rolled back to the previous version. No change.
I noticed that in the Appdata\Lightburn folder there was an .ini and .ini.old file. Got me thinking that uninstalling hasn’t purged them, so deleted both manually, uninstalled LB and reinstalled latest version.
On first run I had to add my machine’s bed parameters as expected.
Repeated rectangle test, now cuts fine :smile:

Any ideas why LB was struggling to communicate in the first place, and why then it seemed to ignore the intended power setting?

Sorry for the long post and thanks for a fantastic product.

1 Like

When you say “same cut parameters” - were they exact? A common mistake is incorrectly setting the Min Power value too low. If you still have the prefs file or those cut files anywhere I could have a look to verify the settings.

I’ve seen comm errors on Win10 occasionally because of Windows’ USB driver interfering with the FTDI driver used by Ruida. You can try installing that from here:

incorrectly setting the Min Power value too low

I will admit to more than once typing the min value in the max parameter box and the max value in the min parameter box.

1 Like

Yes the settings had been remembered from the previous session. All I did was update the text. I’ll see if I can dig out the .ini files from the recycle bin… Thanks

How do I send you the .ini files?

Send to developer at LightBurnSoftware dot com.