Waiting for connection Cohesion3D+Smoothieware

Hello everybody,

So at our shop (luthier) we recently got a EZ4060-DSP 50W CO2 laser engraver.
This came with the stock M2 NANO board in it.
After we tried out some stuff with meerk40t we realised we needed some better software to work with.
So we ordered the Cohesion3D Laserboard with Lightburn software to work with the Cohesion board.

After I installed(Smoothieware drivers as well since we are running this on a laptop with Win7) all the components from the Laserboard with the guide from the Cohesion3D site, I set up Lightburn.
This all went well. Also made some adaptations to the software SD card for some better running operations: as in increasing amperage on the stepper motors, and setting bed size)

So I added the Laser automatically first while selecting Smoothieware and that went all well.
Also adjusted the settings with the Edit button to adapt it to the laserbed measurements etc.
But then when I added the laser and clicked oke, it is just sitting there at “Waiting for connection”
Windows is also giving me a bump all the time when I plug in the USB and saying it is looking for it’s drivers all the time. And than says it fails for installing drivers.

I’ve tried:

  • unplugging, replugging the USB (a good type USB cable, and no longer than 5 meters)
  • Also set the connection for USB to not power off when the laptop thinks this connection is idle, as I read somewhere else here on the forum.
  • Re-installed the Smoothieware driver.
  • Selecting COM port

But it all didn’t help, so I’m a bit clueless at the moment.
If any of you would have something I’m missing right now, that would be very helpful!

Thanks in advance!
Rik

So I have also uploaded some pictures of the mounted hardware.
And a picture of the Console in Lightburn

Hardware 1

Hardware 2

I have the same problem Lightburn finds the board (mks smoothie) attached to ttyACM0, I’m running Linux mint 20.x, but in the console it says waiting for connection. How does lightburn find it but then not connect? I don’t have a windows machine to test it on right now. The prion post indicates same thing happens in windows. It gotta be something simple. I do have permissions to access the usb ports in Linux. Suggestions?
Thanks