"Waiting for connection" message

Just downloaded and installed Lightburn. I USBed it to my OTUR Laser master 2. The software recognized my ORTUR and i added it as a device. Now I am trying to get started but all I am getting is “waiting for connection.” ORTUR is plugged in and live with the blue light burning behind the push buttons on the control pane. What am I missing ???

I had the same problem with my new Comgrow A1 10watt - What I had to do was:
Open LaserGRBL, and tell it to “unlock” my laser.
Close LaserGRBL.
Start Lightburn.

So MY question is, is there a similar function in LightBurn to “unlock” a USB laser connection?
Hopefully this will help you as well.


I’d like to take the opportunity to roll your first post back to the original wording and invite you to answer how you solved it.

There are dozens of new users every week and we’d appreciate your new insight and solution to this.

The discussion on the forum helps new folks and any page can become a landing page for an answer or a new approach.

Let us know how you solved it!

I didn’t do anything. I was apparently too impatient. I left it for about 20 minutes and when I came back I had a connection.

1 Like

Thanks for coming back to this. It’s appreciated.
I had no idea that it would want longer than a handful of seconds to connect.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.