“Waiting for connection” - Unable to connect my Ortur Master 2 laser with lightburn

Hello,
I am having trouble connecting my Ortur master 2 laser with lightburn. I am currently using the latest trial version of lightburn.
It was working fine for days until I woke up one morning to use it.
Under “console” I am getting the message “waiting for connection”.
Under “laser”, I am getting the message “ready”.
I am using a windows 10 laptop.

To troubleshoot so far, I’ve tried to make sure that all the plugs are connected. I unplugged and reconnected a few times. I uninstalled and reinstalled grbl… I turned off computer and back on.

Any suggestions would be helpful at this point because I can’t get it to start up again.

Thanks!

I assume you tried to find the laser, by clicking “devices”, under the LASER tab? The tried to discover your laser? Also, swap out your USB cable. Let us know.

I just set up a Mega2560/RAMPS combo with Marlin and ran into issues that I did not recognize at the time may be the same as what you are having… I spent 3 days debugging…

DTR

I found that if I issue an old school DOS MODE command for the port your engraver is on and enable DTR all works.

Mine was on COM7

Open a CMD prompt in Windows and type:

MODE COM7 DTR=on

Further testing indicates that in order for my workaround using MODE COMx DTR=on you must set the DTR switch in Device Settings to OFF (thats the default but if you have been struggling like I was all bets are off as to what you might have tried!!)

Also GRBL seems to use 115200 baud and marlin seems to default to 250000 baud and I have shot myself in the foot multiple times when switching between them…