Warning after upgrading

Just a warning to all. After running lightburn I got a message to download newer version if I want it.

This I did.

Then after installing and running, and getting ready to cut, it turned on the laser when I clicked FRAME and cost me a small fortune by marking the item I was about to engrave. ffs.

Never happened before.

This is a new behavior change for framing in 1.10.00. If the Fire button is enabled LightBurn will now fire the laser during framing operations. It should use the power level set with the Fire button.

You can disable this behavior by turning off the Fire button in Device Settings. It’s possible that reducing power in Fire button might also have the same effect but not sure.

1 Like

Indeed setting fire to zero sorts it out. I only installed LightBurn about 2 months or so back, so the change is rather annoying. Now to figure out why it’s ignoring deceleration and overburning on the edges…

Thanks for the tip, it is much appreciated.

A few possibilities:

  1. You have configured the device as GRBL-M3 and not GRBL
  2. You do not have laser mode enabled ($32=1)
  3. You are using “Constant Power Mode” in cut settings

Again, thanks for the reply. You are correct, and I had changed all those settings (2 and 3) so sorted out no problem.
However I have used it a fair amount before the update with no issues.

The last one is no biggie at all, but I think the default setting of firing the laser, i.e. damaging something you are engraving, should be off by default. Just IMHO.

Thanks for the reply.

1 Like

Actually, that is still the default. Laser will only fire if the Fire button has been enabled. It is off by default. Also, it will fire at the power level specified in the Fire button setting which I believe starts at 0%.

As I understand the change to enable the firing for framing was due to the huge number of complaints of it not firing. It was one of the most cited questions on this forum.

However, this is likely to be very jarring for those that never relied on firing during framing.

Ok I hear ya, gotta go with the majority I guess. Perhaps the update reset the settings or something? As I said, I did not have this issue before. It was all simple to sort out fair enough, just came as a bit of an omg suprise. For sure my fault for not doing a test before an actual item.

Laser mode wouldn’t be changed by LightBurn. And don’t believe anything was changed with Constant Power Mode. Constant Power Mode by definition disable variable power so if you had that configured before not sure why you weren’t getting burning at deceleration if all other settings were the same.

Not sure about your specific case but I’ve seen laser behavior drift over time as diodes age.

It’s a new machine, AtomStack A5. I am however a Linux user, so would have too see if more complaints come in.

Yes That was a big surprise for me the other day also, I framed the next project and the laser turns on
…I guess with the 1.1 I always need the glasses on…

Please review this,

bevor it was easy to enable the laser by clicking on the button while “Shift”-key was pressed.
This “easy” thing is not possible anymore.

You say that many people complaining about this. But maybe - for safety reason - there should be a parameter for “always on” on for “only with Shift-key”.

I was happier before the update with framing.

This was my point, as sadly I think most people will search for the problem after the fact. To turn off the laser simply set the laser power to 0% when framing.

I’ve made this an option for the pending patch release, so you can decide if you want the laser on when framing by default or not.

1 Like

I guess I"ll just get used to it…I"m sure there’s a good reason why it’s programmed like that. I did my laser down to .25 for help framing. I just didn’t see any warning about the laser fire…I should know better.
I"m all good here just got to get used to it.

You are the best!
Thanks, now framing is secure again.
And when I need to see the laser beam, I can press “Shift”. But then I know to wear my glasses.

Thank you so much for this very fast patch.

This is now an option again, and the default is off, so things should be back to normal for you.

1 Like

Much appreciated thank you.