Weird bidirectional engraving behaviour

Hello all!

Im running into a strange issue and cant find the solution to it.

My machine (diy with ruida controller) was running perfect and i ran into some problems with my TB6600 stepper controllers. I changed the power supply from 24V to 36V and updated the stepper drivers for the X & Y axis to Stepperonline DM542T drivers. I recalibrated the machine (microsteps / steps length) and started to create some products.

During the engraving i noticed i got dual engravings. I’ve found multiple topics on the forum saying bidirectional engraving could cause this. So i turned off bidirectional engraving. This solved the dual engravings (and also introduced more manufacturing time).

When the engraving finished, the cut started. But is was way off… It cut right trough the engraved shape…

To solve this problem i’ve read a lot on the forum and tried the following:

  • Changed Rising edge to lower edge and visa versa → no change
  • Lowered speeds (maybe i was losing steps) → no change
  • Lowered microstep → no change
  • Check play in al belts → no change
  • Checked al my machine settings (i don’t use offsets) → no change

Then I made a simple test with a engraved circle with in cut cirle to create a constant test situation. This is where is started to get strange…

When i enable bidirectional engraving i have dual engravings, but the cut is perfectly centered.
When i disable bidirectional engraving i have a good (single circle) engraving but the cut is way off center.

So for what i can see now, this is related to bidirectional engraving. And i would be very happy to have this function back because it saves alot of time.

I’ve attached an image for clarification.

I hope someone can help me solve this, i’m lost at the moment…

Up! Does someone have an idea? I’m running out of my knowledge… Can’t figure it out and have order piling up :frowning:

The double circle looks like an error in ‘Scanning Offset’.
Imagine the picture in the documentation here with circles instead of squares and much further apart:

You can find the adjustment here:

Since the two circles are equidistant from the center of the circular path (that is not running left to right - but along its path) I don’t think you have lost motion or loose components here.

Leave bidirectional engraving on and adjust (or disable) the scanning offset until the two circles overlap properly. I think that’ll solve it.

It’s related to speed. How fast are you going? :smiley:

Thank you for the response! I will try to get it fixed with these steps. I’ll update here if this worked!

I’m engraving at 300mm/s

But I still think it’s strange this suddenly happens after changing stepper drivers and power supply. Or is there a logical explanation for this?

Sure is:

this is worth review:

This video helped me to understand this subject a lot better! Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.