Whats up with LB? does it really work with GRBL?

Every time I try to connect it takes multiple tries 1 to 12 just to connect. 2nd It also will say “Busy” even thought it is doing nothing. Mostly if I stop a job with the stop button. Only way to get it out of “Busy” mode this is shut down and restart. 3rd quit a lot of LB " not responding". 4th a few crashes as well.

This is what I have:
K40 laser
Mini Gerbil ( control board)
Gerbil 1.1f
Lighburn 0.9.02 trial 4 day left
Windows 10

I have a Mini Gerbil here to test with - it seems that something that changed recently in the communication has affected this specific board. If you send me your trial ID, I can extend it while I sort this out.

LB hangs on “busy” for me as well when using stop or I think even after a limit sw error.
I am using Grbl too.
JTech 7W and Openbuilds frame kit

I had same behaviour on LB 0.8.07.
GRBL and Mana SE board.

Try to delete your device and create it again, that was the solution for me…

Oz, with LB is taking a look. Ill give your sugestion a shot.

Was wondering if you had gotten the email I sent with the trial I.D # you asked for. I was hoping to get the trial extended. Have you tried or found anything about the problems I keep having? Yesterday 4/20, 3 “not responding” and 2 shut downs just to get the “Busy” just to let me do anything.

Have you gotten it worked out?

I think so - I’ve sent you a link to try.