When clicking stop it doesn't send laser stop command


(Christopher Hemmings) #1

If I click stop during a cut. Using tool index 1 it doesn’t tell the laser to turn off. Unsure if it’s tell tool 0 to turn off or not. But tool 1 definitely doesn’t turn off. I assume it is supposed to send m107 P1 but I’m not sure if it sends this or not


(Ray Kholodovsky) #2

You previously posted:

So what is happening now? Did you change your tool index back to 0? Now what is it doing? Please spell out what is and is not happening.


(Oz) #3

You should also either set the laser / firmware info in your profile, or write that when you post, or we have no idea what you’re talking about and have to go digging around your other posts for context.

I’ve looked at the code, and it appears that Stop doesn’t turn off the laser (Pause does though). I’ve added the code to emit the laser disable if you stop.


(Christopher Hemmings) #4

No point me changing it back to zero. My tool is not on that index and I can’t test


(Christopher Hemmings) #5

Thank you. Simple fix by the looks of it