When doing a rotary job, the laser head moves to the previous job's position to engrave

This is a strange one and seems relatively like a “new” problem. Background: We purchased and setup a rotary and most of the provided instructions didn’t work as promised, I seemed to have gotten around those issues by wiring the u-axis to the provided stepper driver and sending the file to the laser and then hitting “Start” from control panel.
We did some initial tests with the rotary installed and everything worked fine. We changed over to some flat work for a time and went back to the rotary recently. However, it seems that the previously working method of sending the file to the laser results in the laser head moving to the previous job’s position to engrave.
We tried a number of different combinations of turning off laser/lightburn/laptop and did eventually get it to work. Then the next day, we moved the rotary tool’s position, did the same steps and it tried to engrave again in the previous rotary job’s position.
I’ve set the laser position in Lightburn to the bottom right of the design and the laser head moves to the correct position. I’ve also set it to start from the current position, as I have for the previous rotary jobs.

Is this a Lightburn issue, a setting that was changed by someone, or is the controller somehow confused about where to start?

TLDR: with the rotary enabled, sending a rotary job to the laser results in the laser head moving to the previous job’s position and ignoring the “current position” in Lightburn.

It’s been awhile since I read something about this. I believe you need to press the Origin button when the laser is where you want it.

I did find a mention of that somewhere shortly after posting. I tried another test today before noticing that discussion and it’s really just rotary work that it does this on. I’ll give the manual origin press a shot and report back if it worked.

I do this on my China Blue I have a PiBurn wheel (roller) rotary.

I assume the U axes homing cycle is disabled.?

I use the Y axes, I set the X where I want it to engrave. Y is lose so I can line it up with the much…

Press ‘Origin’ on the machines console. I set ‘start from’ to ‘user origin’ and ‘job origin’ to left/center. This is where I align the mug to the manufacturers label, assuming it’s at the center.

This should work for you… If you rotary is swapped or going the other way, you can make the ‘job origin’ anywhere want to facilitate job

The Ruida controller has a ‘return’ option in the settings … are you aware of that setting?

I have a photo of it, but the site keeps putting somthing else in there, so I can’t post it.


This is interesting… I don’t follow - please elaborate?

Pressing ‘Origin’ on the machine control panel did the trick.
So the correct workflow for us, since we put our rotary in a fixed position:

  1. place the bottom right corner of our design in the middle of where our cup would be in the Lightburn design space,
  2. Set the laser to that position either with Lightburn’s move interface or via the laser control panel
  3. Hit ‘Send’ from Lightburn (with “Start from current position” selected)
  4. Hit ‘Origin’ on the laser’s control panel
  5. Then hit start.

Glad you’re back up…

You’ll do it again, but you’ll know the answer as soon as it happens … :rofl:

Mark it solved if that’s the case…

Take care


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.