When I activate the Z axis the laser burns a line between the shapes

Hello, I really need help. I will explain my problem. I have an eleksmaker A3 Pro laser and I added a Z axis and the control board has 3 axis. The problem is that when I activate the Z axis and put a number higher than 1 for the number of passes, my laser makes lines between the shapes. What I find really strange is that when I deactivate the Z axis in the parameter I am no longer in line between the forms and therefore my problem is solved. But I absolutely must be able to use the Z-axis to do my job to find more depth in the wood. Thank you ,sorry for my bad English.

We have seen this machine ships with an older version of grbl and I see from your profile you are using grbl v0.9i, so you should be using the GRBL-M3 device in LightBurn. Ideally, you would upgrade to GRBL 1.1f and then use just the GRBL device for the best possible experience using LightBurn.

Check your setting for $30 and $32 in the console by typing $$ and pressing enter.

$32 should be 1 (enable laser mode)

$30 should be 1000

The $30 value can be set either in your firmware to match LightBurn, or in the LightBurn device settings (“s-value max” parameter) to match your GRBL setting.

Here is another great resource for your setup.

http://wiki.eleksmaker.com/doku.php?id=elekslaser_a3_pro

As another member previously posted,

"Scroll down to the bottom "operating instructions" and follow that, once you have it working in elekscam, it should work in LightBurn. Follow the instructions to the letter and that will get you up and running…"

There is also a separate group for these types of machines on Facebook and quite a few people there use LightBurn, so they would be able to advise you more.

I already tried to change the firmware in 1.1f grbl and I damaged the arduino nano controller … And I wrote 1000 for the S value but I’m not the setting $ 32 it tells me Invalid statement

I do not understand what you mean by “damaged the arduino nano controller”. If you are still using grbl 0.9i, did you try configuring your ‘Devices’ in LightBurn to the ‘GRBL-M3’ as suggested?

$32 is not available for grbl 0.9. I was providing that information for you IF you are using grbl 1.1f or later.

Please type $$ into the LightBurn console and hit Return. Copy and paste the entire results here for us to review.

I meant that I tried to change the firmware of the controller in grbl 1.1f but it did not work and it damaged and I do not know how to reset. I put the settings you told me and it did not change anything

$0=10 (step pulse, usec)

$1=25 (step idle delay, msec)

$2=0 (step port invert mask:00000000)

$3=1 (dir port invert mask:00000001)

$4=0 (step enable invert, bool)

$5=0 (limit pins invert, bool)

$6=0 (probe pin invert, bool)

$10=3 (status report mask:00000011)

$11=0.010 (junction deviation, mm)

$12=0.002 (arc tolerance, mm)

$13=0 (report inches, bool)

$20=0 (soft limits, bool)

$21=0 (hard limits, bool)

$22=0 (homing cycle, bool)

$23=0 (homing dir invert mask:00000000)

$24=25.000 (homing feed, mm/min)

$25=500.000 (homing seek, mm/min)

$26=250 (homing debounce, msec)

$27=1.000 (homing pull-off, mm)

$100=80.000 (x, step/mm)

$101=80.000 (y, step/mm)

$102=80.000 (z, step/mm)

$110=5000.000 (x max rate, mm/min)

$111=5000.000 (y max rate, mm/min)

$112=5000.000 (z max rate, mm/min)

$120=200.000 (x accel, mm/sec^2)

$121=200.000 (y accel, mm/sec^2)

$122=200.000 (z accel, mm/sec^2)

$130=5000.000 (x max travel, mm)

$131=5000.000 (y max travel, mm)

$132=5000.000 (z max travel, mm)

If your controller doesn’t have the $32 setting you need to set the S value to 255 - That’s the default for older versions of GRBL, so that could be the issue.

I already try to put the value on 255 but that does not change anything except that the power of my laser has decreased and it always makes a line burn

What happens if you press the button on top of the laser that turns it on at low power for focusing? Another user here had an issue with lines being cut, and turning that on fixed it for him. This makes no sense to me, but if it works…

When I press the button of the laser focus it decreases to make the focus as usual

I meant, what happens if you try to run a job with that enabled?

Nothing changes it stays in focus mode and nothing burns

Can you do this:

  • Draw two squares
  • Set it for Z moves and two passes
  • Click “Save GCode”
  • Save the file as “Squares.txt”
  • Post the file here so I can have a look

It doesn’t look like the Z moves are emitting the M5 command to turn off the beam, so that appears to be a bug. It should be relatively easy to fix. I’ve logged this as a bug in our tracking system.

Thank you for your help I thought it was the version of the grbl that was too awake but as you say it must be a bug of the program … But how long will I wait for you fixed the bug?

LightBurn is in the process of a corporate move from the West Coast to the East Coast starting next week so development will be impacted a bit. Additionally, we never provide a date certain as things can come up that can not be foreseen and can alter or delay the release. As Oz said above,

It should be relatively easy to fix.

1 Like

It’s fixed already. When I’ll have time to release it is another matter, as Rick notes above. :slight_smile:

1 Like

OMG THX I’m really looking forward :smiley:

Lightburn tells me he has an update but it’s the same version number ???

It’s a bug. It’ll be fixed in the next version.