Windows brand new 8mp camera - No Ding and no action

Hello from Brisbane AUS

Finally got my 8mp lightburn camera in the mail today, found it on the door step when I got home from work, very excited I relocated my windows PC closer to the laser and plugged in the camera, Nothing happened. No Ding, no message, no lights (not sure if there is a light).

I have tried on 3 windows computers with the same result. I read on a different post that 5v should be across red and white, I checked and i am getting the 5v on the camera PCB. I also checked continuity on each wire of the USB lead and it seems ok.

I did notice a small component near the connector that maybe looks suspicious. It is black but I can see a little copper colour from one corner. I am not sure if this is normal, i cant find a good picture online where I can tell. I have tried to include a picture.

What are your thoughts? Faulty camera?
Cheers
John

If you haven’t already, please do send us an email so that our customer service dept. can take care of this for you.

The component you point out looks somewhat like a power inductor, and it’s possible that the case is just chipped and the wire inside is still intact. I’ll think about it a bit more.

It does look like a coil, its hard to tell if its intact.
I have emailed the support email address listed on the website.
Cheers