Wiring up a new PSU and GRBLHal installation

My PSU has a TL and 0-5v PWM IN for intensity. I have the GRBLHal Spindle EN pin going to TL and SPINDLE PWM pin going to the IN pin on the PSU. The intensity seems to be going the wrong way wired up like this. With an S value of 1 its at full intensity and an S value of 100 its basically off. I had to do this once before but I can’t remember for the life of me what I had to do to make it work properly. Any thoughts?

Don’t have a K40 but on my China Blue the L lines ‘enables’ (goes low) the laser and the ‘IN’ line is for the pwm.

What I’m suspicious of is that the EN line on your controller is going high to enable the laser. So you would end up with it inverting the duty cycle… sounds similar to your issue. In the photo you can see the H pin (unused,) which is used for a high enable. Does your lps have a ‘TH’ or ‘H’ like mine? I’d check this first… Follow?

Then I’d ask did you go through the Lightburn GRBL setup?

Don’t know if this photo is a help or hindrance

Good luck :smiley_cat:

hi jerseyguy please Uncomment “#define INVERT_SPINDLE_ENABLE_PIN” from config.h :relaxed:

Thanks for the comment. Don’t know all of these machines so wasn’t sure how to correct it at that level.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.