Work space and laser not agreeing

I installed my new Ortur YRR rotary on LMP2. After set up I tried a test and the laser head ran into the right side of the carriage and then nothing worked. I removed the YRR and reset the default settings. Still nothing. I reset origin to 0 0 and the laser returns home properly and prints but the final product is a fraction of the size it’s supposed to be. It’s likely that I clicked too many buttons but I messed something up. Any help?

You should always make a copy of the settings on your controller before you modify anything. If you lost your controller, how would you recover? Most of these are generic, so it could be an issue.

If you had that now, you would be back operating…

I’d suggest you hope for a response from @OrturTech, they can probably do a better job than I at getting you back up… There is a Ortur area for posting in Lightburn.

Good luck

:smiley_cat:

I did save before I changed settings. Reloading those settings did not change anything.

Good job on the save and restore, saves all of us headaches…

At what point does the operation change from your previous use.

You should check to ensure that both the laser and the software are in measurement, inches or mm. That’s responsible for lots of grief.

:smiley_cat:

As far as I can tell both are in mm.
I’ve been engraving successfully for several months. Things went south when I tried the rotary for the first time.

There’s almost certainly something different in the configuration that was missed.
Try this:

  1. take another backup of your current settings (not overwriting your original backup).
  2. Run a $$ in console and paste here.
  3. Issue $RST=* in console. This should default all settings.
  4. Rerun $$ in console and paste here.
  5. Test for functionality.

2 and 4 are more for the benefit of the community and not strictly necessary.

1 Like

Thanks for the feedback. I ran the $RST=* and it worked. However every time I set up the YRR I get the same problem of the carriage running hard to the right. Resetting solves it each time but it’s very annoying. If the laser goes into sleep mode I have to reset again or it slams to the right. Right clicking in devices does not work.
Furthermore when it did work it gave me a mirror image from what was in my work space.

How exactly are you setting up the YRR? Are you pulling up a saved profile or are you reentering values? What values are you setting?
Did you resave the known good configuration after resetting?

I suspect you have more in your saved profile than you think that’s not getting restored.

This seems to indicate that your machine origin was changed?

Settings changed:
1 turned off soft limits
2 turned off homing cycle
3 show rotary on main window
4 enable rotary
5 turned off return to home at startup
I saved original settings and rotary settings. I tried both saved settings and re-entering settings with the same results. My IT service company tried completely deleting everything and reinstalled with the same results.
I might try leaving all original settings and just enable rotary to see what happens.

At a minimum you’ll likely need to turn off homing as the rotary will keep turning if you don’t.

But it’s odd because none of configuration changes should be requiring a reset.

There are new firmware updates for your line of lasers. Maybe worth an update to see if that changes anything. There’s always a risk to these updates of course.

The rotary seems to be working now but I’m always ready to hit the stop button. It still wants to slam to the right once in a while. I hit stop and try again and most time it then works. Weird!
The bigger problem now is that it still prints a mirror image of what I have in my workspace. I suspect these two problems are related.

I saw some suggestions to turn the rotary around so the stepper motor is on the right. That fixed the mirror image problem. It doesn’t make sense to me but as long as it works I’ll take it.

Does left and right still match to what’s onscreen or is that now flipped? If flipped, then try putting back to the “normal” orientation and try using the “Mirror ouput to Rotary” to address the mirroring.

Left and right are normal. Just backwards

Mirror output to rotary worked. But now it gives me warning that I might be out of bounds.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.