Working area is too small

Dear all

I am newbie to Lightburn.
My problem is that the working area is too small for what i mentioned in the settings.
My Machine is Laseraxe firmware v0.8 . Size= 500 x 600 mm. But when i try to work
it only let me use a small area .
What is wrong or what am i doing wrong.
As you see in the Pic . the X is from Zero to 127 and the Y is from Zero to 163
and there is the working area i can work at only.

Please tell me what am i doing wrong
Regards

What do you mean? Your work area is the area that is filled with a grid. What’s stopping you from using the remaining space?

I don’t know whats stopping me. if an object is bigger than the black box , it will hit the rail at the other side.

Guessing this is a new installation and machine settings for steppers is wrong. Assuming the laser works, try telling it to cut a 10mm line then measure the line to see what it actually is.

Yes new installation

Ok i will do it

Thanks

It’s also quite possible that you don’t have homing switches and haven’t zero’d the machine. Try this:

Click this button:image

Then click in the lower-right corner of the workspace with the mouse, which will jog the laser there. Where does the laser actually go? If it’s not at the bottom right corner of the work area, you need to use the jog controls to move the laser head there, then enter:

G92 X0 Y0

… into the console and press enter. This will set the zero point of the machine.

Yes i don’t have a homing switches but the machine is zero’d as when i press at the Go to origin
it goes to the corner down left and the Get Position are zeros for X and Y

I typed the command G92 X0 Y0 into the console and asked for Position , its zeros.
I drew a straight line 167 mm tall from the bottom of the chart and pressed at Start , it moved and
reached the other side.
Its still the same . Any help

Thanks in advanced

That sounds like a configuration issue then. If you draw a 10mm square, does it come out to about 39mm? If so, then your GRBL device hasn’t been properly set for stepping sizes. This could happen if you updated the firmware but didn’t save the settings, or if it’s a new controller on a laser that it didn’t originally come with.

Go to Edit > Machine Settings and look at the bottom in ‘Vendor Settings’ for the steps per mm values for the X and Y axis. Or, using the console, type $$ and press enter, and look for $100 and $101. Tell us what they are. https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration#100-101-and-102--xyz-stepsmm

Those values are likely too large (according to my math, you need to divide them by roughly 4)

Hello

X & Y steps / mm are 400 .
I guess it worked , i made them 100 instead of 400 and now i am using the whole area.
I will burn some lines and measure them .

Thanks again