Wrong cutting order :/

I would like to ask, if there is something I am doing wrong, or is it the software’s issue and it was still not fixed?
I have asked this a few months ago here and got told, that this is the LB’s problem and will be fixed in 1.3.0
I just upgraded to 1.3.01 and it is still not working properly.

→ Look at the video - the cuts don’t make any sense to me.
It is not such a big deal, but it is really frustrating :smiley:

Without the file to play with I’m not sure how to choose optimal settings, or even what cut order you’d prefer.

What happens if you turn on “reduce travel” and turn off “reduce direction changes”?

You can see that the laser jumpes far from the last cutting object. That is not good or optimal - I want the laser to move on the nearest shape…Or you think this is ok?

This picture is after I turned on “reduce travel” and turned off “reduce direction changes” - still didn’t help.

PS: with the settings before I even got the outline cut out before some of the inner parts - and that is realy bad :frowning:

I would really like to solve this problem, because it is pretty dangerous when cutting shapes and the laser head moving around without any order - it can hit way more cut pieces than when there is an order.
I was told it would be fixed in 1.3.00 (it is also why I paid for a new license :sweat_smile:)

After I upgrated I got also another problems:

  • Like the language - it is not translated all as it was before - it is just annoying.
  • When I open my Library - look what it does!
  • When I assign to a layer - it does not get locked as it did before - so it is not so clear and easy to see it is assigned already…


Hehe a few days ago I wrote how happy I am with this software and it is still true, but that does not mean I don’t need to solve this problems, LB team :slight_smile: :exploding_head:

Also, I can’t see how many objects I have selected - that is also quite annoying:

Perhaps some “objects” are not closed shapes: a single letter or other pattern (which you and I would think of as a single object) consists of dozens of disconnected lines (each of which LightBurn counts as an object).

If that’s the case, then the 811 objects shown in the status line is correct and is showing you all of the selected objects.

The info in the status line is correct for 100%. I tried to point out, that the information is halfway hidden :expressionless:
On that picture there are actually 8112 objects - but I can’t read the “2 objects”
Sometimes I can’t see even bigger part of the number :dotted_line_face:

This seems like a powerful motivation to reduce the number of objects you have floating around out there! :grin:

I often have the same problem in web browsers, where I force larger fonts for easier reading and the web page designer forces them into small boxes to get more empty space in the page. There seems to be no solution to that problem, other than insisting web designers use older eyes to check their work.

Thank you for letting us know.
We are working to correct the translations.

I have logged this translation concern with the team.
The Support Ticket number is #83824.

I will review other conversations that we’ve had about translations and log those concerns right away.

If you’re willing to share the lbrn or lbrn2 file I may be able to find or generate a smoother cut order.

Thank you. The translation is annoying yes, but the smallest problem I have.

I can share the LB file. I am curious how you want to make it smoother? Like just for this one file? Because this is not a problem of only one project…Or find and fix the bug in the software based on my file?
CEMA logo - cedule.lbrn2 (1.1 MB)

Do you know something about the error in the library? And the assinging to the layer? Or the status line object info?


I see that you have Grouped each letter that has an inside shape and selected Order By Group after Order By layer. Groups can be identified when selected. The groups have a distinctly different ‘selected’ dashed line. For a group the ‘selected’ line appears as dot-dot-dash instead of just dashes.

Since all the Groups are on the same layer it proceeds to engrave the groups in order from left to right.

With these settings I experienced the same convoluted path.

I tested the following settings:

I got the following result:

Rapid moves have been changed from 4742mm ( 16 seconds ) to 2262mm (9 seconds). The non-linear relationship between distance and time is caused by the acceleration and deceleration between the rapid moves and the engrave moves.

I am optimistic that this seems less random.

The letters from the font are vector paths. The start node locations for the paths are preserved when they are rotated.

2023-02-17_13-27-14 start nodes in Letters

By reducing the distances between the end and start points between letters further optimization will be available to you. You are welcome to move and rotate the letters to shorten the distance or change the location of the start nodes letter by letter.

I also attempted to optimize the the shape of the letter C but it’s at 23 nodes so it’s not as bad as it looks.

This is a limit of font size and screen size. This appears to be a small laptop monitor like mine. LightBurn is expected to work on some fairly small laptop monitors and some huge design house hardware. The font and tile sizes are adjustable in Windows 11 but you may have a more pleasant experience with a larger or an external monitor.

In 1.2.01 an option was added to Assign to allow it to not be Linked:

Notes on the more recent Material Linking feature are in the 1.2.00 release notes:

This may offer some clarity.

Thanks! I didn’t know that the groups make this “problem”.

  • The letter “C”…that is how LB makes it when I convert it into the path.

It is definitely better, thank you.
I still can’t help myself…what do I need to do if I want the laser to start cutting at the nearest point of the nearest object? (Without manually setting it up?)
Like I would rather if after finishing the letter “A” it started at the neareast possible point of the letter “C”…but the laser goes all the way back there:


I get that. Yes, smaller monitor…but would it be too difficult to make it adjustable?
Because the right 1/3 of the status line is empty…and that seems silly to me. And a bit upsetting when I need to manually count the objects, because I can’t see the amount on the monitor…


Thank you! I don’t always keep up with all the upgrades - I just get confused when all the sudden something works differently :slight_smile:

What can I do about this error?
It makes it hard for me to orient myself in the library.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.