X-axis offset during engraving with a Neje master 2 170x170

I am engraving photos on wood and as you can see in the attached photo, there is a large offset on the z axis, which is moving to the right. I have already burned around forty photos without having this problem. I don’t know how to fix this problem. I uninstalled the driver, reinstalled it, but the problem persists. However, if I engrave a black rectangle, there is no offset. I think it comes from the differences in the gray values that disturb the movement of the head. Does anyone have a solution to this problem? With thanks

Should this be “Z-axis offset…” for a title?

Can you actually see the z axis move?

Might want to upload the .lbrn2 file for people to inspect.

Maybe a better photo or something, I can’t see your problem. Of course I’m old and blind… :slight_smile:

I think you meant X axis. With your laser there are two possible causes:

  1. The belt that moves the gantry from the X Motor is either too loose or too tight (causing binding), or…
  2. Your X acceleration parameters are too high and it’s losing counts.

That it shifts the same way each time I’m betting on the belt adjustment.

Looked at both, too blind to see it in the picture or don’t know what I’m looking for :slight_smile:

Thank you for all your answers. The problem was that during the engraving the head shifted to the right. Instead of being a rectangle, the engraving became a trapezoid. But I found the why, in the images there is an alternation of blacks, grays, and whites. At each white srface the speed of movement accelerates, and slows down on darker surfaces, eventually creating a shift.
by slowing down the engraving speed, going from 8 to 12, I solved the problem and there is no more lag.
thank you again for your answers

Glad you’ve found the problem. Please mark it solved.

I assume you meant from 12 to 8… :slight_smile:

Take care. Good luck.

thank you, it"s resolve