X-axis stepping is way off

Hey everyone. I’m brand new here. My wife has a craft business and bought me the cheapest laser engraver on Amazon last year. The name brand is “Adngom” and I can’t find anything about them online. Anyway, I downloaded a trial version of Lightburn after being disappointed with LaserGRBL. Currently, I’m having issues establishing home and keeping it.
When I have the machine set to 0,0 I can step it in either direction by 10mm. But when I step it more than one time on the x-axis, the “current position” reflected in Lightburn is way off. For example, I set it to 0,0 then step it once by 10mm along the x-axis. Ok, the current position is 10,0. Then I step it one more time and the position shows up as -119.96,-320.00. For the life of me I can’t figure this out.

Also, I’m not even sure where to go to update the firmware if that might help my issue.

$$
$0=10
$1=5
$2=0
$3=1
$4=0
$5=1
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=1
$23=1
$24=300.000
$25=1000.000
$26=250.000
$27=1.000
$30=1000.000
$31=0.000
$32=1
$38=1
$37=1
$40=1
$100=80.000
$101=80.000
$102=80.000
$103=100.000
$104=100.000
$105=100.000
$110=10000.000
$111=10000.000
$112=10000.000
$113=1000.000
$114=1000.000
$115=1000.000
$120=500.000
$121=500.000
$122=500.000
$123=200.000
$124=200.000
$125=200.000
$130=432.000
$131=406.000
$132=80.000
$133=300.000
$134=300.000
$135=300.000
ok

This has limit switches, and you home it with home button, correct?
Which corner does it home to?

Yes, it has a home button. I forget exactly where it homed to when I first powered it on, but I turned it off, manually moved the laser head to the front left position (closest to me) just now. I jogged it closer to the center and pressed “home” and it went back to the front (bottom) left. Does that make sense?

Can you also type in $I and paste here.
Some info that may help.

Here is the $I information:
$I

[VER:1.1h.2022111903:]

[OPT:PHSW]

[MSG:Using machine:MKS DLC32]

[MSG:Mode=AP:SSDI=MKS_DLC:IP=192.168.4.1:MAC=A8-48-FA-56-89-DD]

ok


When I pressed “Home” in the LIghtburn Move tab, it tried to return to wherever home was but it was just crashing into the frame and made this horrid grinding/clicking noise until it just gave up. THis is what it shows in the console output:
ALARM:9

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.

ok

Grbl 1.1h [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

ok


When I typed G0 X0 Y0, it returned to the bottom (front) right corner.

When I typed G0 X10 Y10, it bumped into the rails and didn’t move.

Home should be wherever your switches are located.
Can you also type in $# and paste here.

I’m not sure what you mean by “switches”. But here is the output.
$#

[G54:-400.000,-400.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

You have microswitches that are used to home your laser, probably one in left bottom corner and one on left side of Y axis. That’s where your laser should travel to and trip each switch.
Also you have an offset applied that I would clear with $RST=# command and see what that does for you.

It is working a little better now, but I loaded a .svg file and it acts like it discarded the settings I had configured. I ran the command for the Negative Coordinate Machine setup and that seems to have helped.
As far as the switches go, I looked all over that thing and can’t find the switches. I noticed when I toggle $20 and $21 to 0, I lose the home ability, but the machine doesn’t crash into the frame any longer. I can just navigate by pointing to various points on the drawing and it goes there without issue.
I am tinkering with the speed and power settings

You had homing enabled and if it homed at one time you must have switches installed.
If you don’t have switches, then you need to home your machine manually by turning it off and positioning the laser at lower left and then turning machine back on.

Maybe the stepper drivers are the likes of TMC that “senses” the stop at home position.