XTool F1 - can you default red laser for file?

Running Lightburn on the F1. I have several different files but every time I open a file to engrave metal I have to click a tab and enable the red laser in order for it to engrave. Is there a way of enabling the red laser in the file itself or the machine settings?

On my machines, the device sets which configuration it has… I don’t have one of these nor a LaserPecker 4, so I have no direct experience…

:smile_cat:

Yes, you can by changing the “Start Gcode”. It’s found in edit < device settings < G code. In the “Start Gcode” area, add M114S2 without any punctuation. However, you’ll have to remember you did this as selecting the blue laser will now no longer work from the menu.

2 Likes

Thank you so much for this answer. You saved me a lot of headache!

So, you could make 2 machine profiles, one for red and one for blue and just switch back and foirth like that, no? I’m going to be helping a local maker get her F1 up and running this week or next so this would be a helpful point for her. I’ll give it a try

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.