xTool GRBL - ChromeOS - Linux - Lightburn USB Connection Issues

I’ve successfully installed LightBurn on Chromebook. I’ve been able to open it just fine. xTool D1 Pro laser is showing as ready, with ttyUSB0 drop-down selectable… but get “Communication with controller failed” under machine settings and no response to movement commands.

Successfully added to group ttyl and dialout
ttyUSB0 shows next to device
ch341-uart converter
GRBL controller
Latest Lightburn
xTool D1 Pro latest firmware
Running VM Linux penguin 5.10.131-19155-g2e2fb0ed324d x86_64

Checked as many forums as I could to no avail. I’m pulling my hair out trying to get this last step to work and am not sure where to go from here.

Please let me know if you have any tips!

How did you configure the xTool in LightBurn?

Can you take a screenshot of Edit->Device Settings?

Have you confirmed that you can connect to the D1 Pro in GRBL mode in another computer?

Hi berainlb,

Installed LightBurn with key using the LightBurn Linux Installation page. Downloaded the lightburn xTool-D1ProV3.lbdev config file off xTool and imported. Added to groups dialout and tty. Also tried find my laser, which after switching off and on showed and came in as GRBL-m3 1.1 or earlier. That version does not work as well.

GRBL connection works without issue on desktop. Laser responds as expected.

Screenshot 2022-09-23 3.08.11 PM


This should rule out any basic configuration issues.

This rules out any issue on the laser side.

Definitely don’t want this.

So I’m probably caught up to where you already are. Issue most likely isolated to ChromeOS/Linux specific issue.

Does Console show anything other than “Communication with controller failed”?

Can you run these commands in a Terminal?

dmesg | grep -i ch341
lsmod | grep -i ch341

Not a Linux native, so let me know if I misunderstood:

Screenshot 2022-09-23 3.18.31 PM

Crap. Just noticed the ch340/ch341 mismatch. I’ve read ch340 may not be resolvable here…

Also noticed I botched the entry… see correct commands below:

Can you take a screenshot of the Console window in LightBurn? It should be on the top right pane of the main screen. If the tab is not available make sure Console is enabled in Window menu.

Can you try connecting to the laser from Terminal?

sudo screen /dev/ttyUSB0 230400

Once connected, try issuing some commands:


Use exit command to get out of screen command.

For the multiple “device disconnected” messages. Do those correlate to times you’ve reconnected the machine or recycled power?

Screenshot 2022-09-23 4.02.46 PM


I suspect they are connects and disconnects on my part. They dump at the same time, and after closing lightburn and terminal, re-issuing the command, the same log returns.

I have been able to get info off /dev/ttyUSB0 before. Not sure why it’s not showing currently.

Apparently the screen command doesn’t ship with your installation.

Try this. Can you cycle through the various baud rates in Edit->Device Settings? Just go slower one at a time and try connecting. You may need to right-click on the Devices button in Laser window to force a reconnect. Make sure that the port is still selected.

I do need to reattach the USB connection after each disconnect
Screenshot 2022-09-23 4.12.59 PM

I did notice this message when clicking device:
Screenshot 2022-09-23 4.16.32 PM

Tried a couple common baud rates before, but I’ll cycle through and let you know what I find.

Thanks again for working through this with me, I’m pretty lost.

Multiple times you stated this so I think you don’t know what that is really doing and may be doing it incorrectly. What’s going on is that Linux/UNIX has users of the system and each user gets a User ID to use the machine. Even if you are the only user on the machine you should have a userID.

Each user, userID, gets rights to access only certain parts of the operating system so when a user wants to use a device, like /dev/ttyUSB0, then the user has to be added to the group which is associated with the device. Often it is the dialout group.

So what we’d want to hear is that you added the userID to the dialout and tty groups.

If you don’t add the correct userID to the correct group it will not work. I don’t know if your Chromebook gives you a command prompt but if it does, try typing “whoami” and it should show you who the user of that console window is. IIRC you would then use “sudo adduser $USER dialout” to add the userID stored in $USER variable(same as ‘whoami’ showed) to the dialout group.

You would also want to see what the /dev/ttyUSB0 device is setup as. Use this to see the long list:
ls -l /dev/ttyUSB0

You should see something like: crw-rw---- 1 root dialout 4, 64 Sep 20 20:27 /dev/ttyUSB0
Where you can see it shows “root dialout” which means the device is part of the dialout group and you have correctly added your user to the correct group.

No luck. Tried going down from 234000, switching to my other USB port, then going back up.

May or may not be noteworthy, but every time I switch USB ports the drop down cycles up 1… ttyUSB0 >> USB1 >> USB2 all the way up to 7 then it drops back to 0. Maybe I’m playing ring around the rosy with the ports connections?

While potentially annoying this shouldn’t be a fundamental problem assuming that permissions are addressed.

Ok. This is weird. Just for records sake, I did not run any additional commands to tty or dialout to $USER or any other var.

I do understand permissions, and why Linux is more secure through walling root, and whatnot. I’m not sure if I literally granted userID or my b4sommer user originally.

After power cycling the laptop, and connecting linux automatically through lightburn app, I’m now seeing the following and have laser movement!

Screenshot 2022-09-23 4.46.25 PM

I honestly am still not sure what the heck I’m doing, or not doing, wrong here. I did disconnect the USB and reconnect to verify it was still on USB0. Will let you know if the situation changes… after restart?

1 Like

Haha. There may be something that required the reboot for it to take effect properly. But looks like you’re in business.

It’s back to squat. I’m sure I’m being dumb here. I’m a product engineer with a programming background and my close friends tell me so regularly… CRIES (very) sadly

To be fair, from what I’ve seen xTool controllers tend to be temperamental when it comes to connectivity.

Do you recall what the USB port number was when it did work?

Try listing the device as @DougL suggested:

ls -l /dev/*USB*

Screenshot 2022-09-23 5.13.10 PM

I’m scared… and feeling a bit vulnerable…
Screenshot 2022-09-23 5.14.08 PM

Screenshot 2022-09-23 5.14.36 PM

@Democreous yes, once you add a user to a group you have to log out and then back in… or reboot.

You were messing with baud rates and that is likely why you got garbage data for a bit.