Y set to wrong position after Homing

Hi. I have updated the controller on my neje 2s max. I have everything working except the y axis homing. 0,0 should be on the front left after homing. that’s the way the settings show it being. My machine homes on the back left. After homing with laser position sitting on the back left it reports a position of 0,0. should be 0,18. After homing when I commanded g0 x0,y15 it gives me a " G-code motion target exceeds machine travel." I’m stuck. Any ideas.

To what? That might help us …


Sorry the board is a makerbase mks dlc32 v.2 with mks ts35_r display. I’m running grbl to interface. Zed

You’ll likely need to set an offset if you didn’t customize the source code since it will assume that home location is 0,0.

Can you run this in Console. Then rehome and recheck home position? I suggest you take a full backup of your GRBL config as a reference.

G10 L2 P1 X0 Y460

Ok done. That helped. When i entered setting you suggested it homed and it said y= -460 and when i jog towards 0 the negitive numbers get bigger. Should be +460 and get smaller towards 0.

Okay. Was wondering if that might happen. Try this:

G10 L2 P1 X0 Y-460
1 Like

That did it!! Thanks so much.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.