Yet another rotary question

chinese blue/white, ruida. got the rotary hooked up, did a test burn on 20mm square. default steps were 10,000. square came out to 20mm on X and 2mm on rotary. Seems like I need to adjust to 100,000??
also, rotary enabled is not always on, if I deselect and click ok, if I go into the tools/rotary, it is still selected.
I’m not often lost but this one has me
thanks for any help

my machine is now stuck in rotary enabled mode

ok… strange… after several rstarts and power cycles it has corrected itself. I have my steps corrected correctly and we’re good to go. feel free to ignore this post

The rotary switch on the main display only updates when LightBurn connects to the machine. If you power up your laser after starting LightBurn, it won’t happen until you send the first job. You can also right-click the “Devices” button, or click “Devices” and then click “Ok” - both of these force it to reconnect, and will update the rotary button state.

got’er all sorted, thanks… 100% user error