Z-Axis Auto Focus, How to Setup?


(Steve) #1

I’ve been using one of these Auto Focus sensors for a while now (the red pen looking thing in the photo below). It’s a simple limit switch. I tell the machine to focus, the Z table moves up until the tip touches the material surface then moves back down a set amount to set the focus point to the surface of the material. Then I feed the material offset (in or out depending on cutting or engraving) into Lightburn. I had it setup (probably incorrectly) in V8 but it was working for me. I updated to V9 and I could no longer get Auto Focus to work. So I downgraded back to V8 and have been using it since.

Fast forward to yesterday and I “upgraded” my laser controller from RDC6442S to RDC6445G. This includes a new keypad with a Focus and Z up-down buttons instead of having to navigate through the menu. This is great but my Auto Focus settings from before are no longer working. I’ve transferred my vendor settings over from the original controller. I click the focus button, the laser sets the correct focus height but the Z axis no longer responds to the Lightburn offsets when running a job. So I tried the latest V9 software thinking maybe I need a newer version Lightburn for the newer controller but unfortunately it doesn’t make a difference.

What would be great is if there was a guide somewhere that shows the correct way to setup Lightburn w/ these simple Auto Focus sensors. I really would like to get the new controller working along w/ updating to the newest Lightburn software but can not without a functioning auto focus. Please help.


(Rick James) #2

LightBurn does not have any specific guide as LightBurn has never done anything with auto-focus aside from having a button you could push to run the focus probe cycle setup on your hardware. To enable this button in the ‘Move’ window, turn ON the ‘Enable Z axis’ in the ‘Device Settings’ window.

image


(Oz) #3

Auto-focus is a function of the Ruida controller, not LightBurn. It’s essentially a Z limit switch, wired to Lmt -Z on the controller itself. When you press the Focus button, the controller raises the Z axis until the limit switch is tripped.

The software has no influence over this, other than sending the command to start the process, or the ability to edit the machine settings that would enable it. There isn’t anything in LightBurn that I’m aware of that would affect the ability to use auto-focus from one version to the next.


(Steve) #4

I forgot to enable the Z axis for the new controller as Rick suggested. It seems to be working correctly now. Am I correct in that if I have “relative z moves only” checked then the material thickness has no affect on the Z movements? It’s only used to organize the library?


(Oz) #5

Correct, regarding the library.


(Steve) #6

What does unchecking “relative z moves only” do?


(Oz) #7

Does all Z moves in absolute values, meaning that you must have the “Material (mm)” value on the main panel set properly to get the correct Z height.


(system) closed #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.