Z axis do not move between passes and layers

I have 1.1f installed on my eleksmaker A3 with a z axis and home switches.

Now two issues:

  1. The z axis is not homing while the x and y work well.

  2. If I set a z step per pass of 5mm for example and three passes, the z axis is not changing between the layers. Also Z offset of different values between different layers, the z axis is not moving. However, under Move, I can command the Z axis.

Here are my grbl settings:


Thank you for your help

Have you enabled the Z in the device settings? Many lasers do not have a controlled Z axis, so this setting is off by default.

Thank you! You both had right. I didn’t know I had to turn the z-axis on. Problem number 2 solved.

What about homing on z-axis? Still not working

LightBurn just sends $H to the board to trigger the homing cycle, after which GRBL takes over. According to the GRBL docs that should just work if you have a Z, but there may be different compiled versions that have that disabled - I’m not sure. https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration#22---homing-cycle-boolean

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.