Z axis homing not working


(Bob Waterfield) #1

I am in the process of adding a Z axis. I have it connected to my controller and enabled in LB.
I have set $132=50 for the travel.
I can control/move it via laser movement buttons.
When I issue a HOME command, only the X&Y axis home, Z stays put.
I had the laser do a simple circle 2 layers deep with a start Z@10mm and a second layer of Z=20mm
The Z axis did correctly move by these amounts.
What did I miss?


(Oz) #2

If you have a GRBL controller, you may need to get a version with Z homing explicitly enabled.

In LightBurn, I just send $H to home the controller, so this will be a config issue with the firmware. Check here: https://github.com/grbl/grbl/issues/1315


(Bob Waterfield) #3

I am running GRBL 1.1f.
I have also posted on Spark Concepts forum.

Agggg… never easy


(Bob Waterfield) #4

Oz,
Got her going.
It was the special release of GRBL from open builds I had loaded. 1.1g
Reloaded 1.1f and all is well.
Still not quite understanding something.
Have Z axis configured to raise to a home position.
At the start of a job, (figuring Z zero = a paper target)
If I have material thickness set to zero, the Z axis does not move. Should it not move down towards the target?


(Oz) #5

That depends - if you have “Relative Z moves only” enabled it will only make moves relative to the initial Z height. It also depends on where your zero is.


(Bob Waterfield) #6

Will check the relative Z setting.
Z home is up with a 10mm move away from the switches.
I will assume that it should lower the Z axis to what ever distance $132 is set for.


(Bob Waterfield) #7

Ok I turned off Relative Z settings.
My Z axis will home (raise the Z axis) off the bed.
If I start a job, The Z axis moves downwards slightly and the job runs.
I fail to see anywhere to tell Lightburn how much to lower the Z axis at the start of a job.
I do see the material thickness setting, I also see the steps per pass setting, both are at zero.
Other than the $132 setting, what tells the Z axis to move down to Z zero.
I DO NOT have a bed that raises type Z axis.
It does not make sense to home the Z axis in a down position at the job start.


(Oz) #8

If you are not using relative Z moves you need to set Material (mm) to the starting value for Z height. Having it set to zero is likely why the software is lowering the Z when you start the job.


(Bob Waterfield) #9

I agree, it is trying to work, but it only moves Z down a few mm at the job start, when the material thickness is set to zero. It needs to move almost the full travel (50mm) for a zero thickness.
Unless Material thickness needs to be a positive number (0.01mm)?


(Bob Waterfield) #10

Did some testing:

  1. Running GRBL 1.1f
  2. Homes Z in an upwards direction. ( Z mounted to gantry not the table)
  3. At job start, Z moves 1.5mm in a downward direction. ( material thickness = 0 mm)
    Thought it should move in a downwards direction way more.
  4. Start the same job again, Z moves another 1.5mm down.

I have it homing ok.

  1. Why does it just slightly move at job start?
  2. How do I have it move closer to target at job start?

(Bob Waterfield) #11

I had a look at the Gcode:
; LightBurn 0.8.07
; GRBL device profile, current position
G00 G17 G40 G21 G54
G91
M4
; Cut @ 1000 mm/min, 100% power
M8
G0X0Y0
G0Z-39.97 <----Why is this being sent?
1Y43S1000F1000
G1X69
G1Y-43
G1X-69
M9
G1S0
M5
; return to starting pos
G0 X0Y0 <---- Why is Z not returning to home?
M2


(Oz) #12

Likely because your starting position is 39.97mm above zero, and you have 0 set in the “Material (mm)” setting.

As I keep saying, that setting controls the baseline Z height for the whole job if you aren’t using relative Z moves. You need to set it to the height you want the Z during the job, or set Z manually and use relative Z moves.


(Bob Waterfield) #13

I have NOT given any commands to change the Z height after it homes. It should stay at home position durring the job.
I fail to see where it is being told to move 39.93 at the job start. Material height is set to zero.
This is a single pass job with steps per pass set to zero.

I fail to understand why it will not return to home at job end.

There needs to be a setting of where Zero is, so that the Z axis can home in an UP direction, and then lower to a Z start position just above the bed plus what ever material thickness you have… I fail to find such a setting.

Right now, I had to change my set up so Z home is just above the bed, I can use material thickness to raise it up higher if need be. But is still moves UP 39.93. when is should not move at all.
There is a GRBL setting for Z max travel ($102) but I do not see a Lightburn setting for Z travel or where start should be.


(Oz) #14

If you have “Z Enable” set, and don’t have “Relative Z moves” set, then you absolutely have given a command to move the Z when you hit the Start button. The Z moves to the height set by “Material (mm)” on the main panel. That’s why I’m trying to tell you to enable the “Relative Z moves only” button, so that it doesn’t do that.

Right, and unless your material is infinitely thin, it shouldn’t be set to zero. This zero is the height that LightBurn is moving your Z to when you press Start, because you’ve told it that this is the behavior you want.

You said Z height is 50mm, with a 10mm pull off from the switches, which would be 40mm, or 39.97mm if the machine overshoots a touch. A -39.97mm relative move at the beginning of the GCode is exactly what I’d expect to see if you set the material height to zero.

If you want your initial Z height to be the baseline height for the job, enable the “Relative Z moves only” button in the Device Settings.

Read here: https://github.com/LightBurnSoftware/Documentation/blob/master/DeviceSettings.md#z-axis-controls


(Bob Waterfield) #15

In this case, I am trying to cut some card stock. 0.01mm thick.
I have relative moves ON.
Material height = 0mm
Cut single pass 1000mm/I 75% on the laser.
The Z axis should home (it does) and NOT move.
Start the job and I see the Z axis move.

From the link you sent me:
Relative Z moves only:** **This setting tells LightBurn to read the height of the machine when the job starts, and uses that height as the starting point for all Z moves, ignoring any specified material height. This is the simplest way to work, as you just set your focus manually, and LightBurn will perform all moves relative to whatever height your machine is at when the job starts
I do not see anywhere to tell LB the height of my machine.
Home =0
Material height =0
Z axis move should =0


(Ray Kholodovsky) closed #16