Z axis is driven into stops

I get the following error when I try to home the laser.
Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

I do not have limit switches installed (on order). Is there a way to set the z axis? I don’t want it to move once I’ve focused the laser. Everything works when I use LaserGRBL.

Disable Auto-home on startup in Edit->Device Settings.

Lightburn does have the ability to control the Z axes. Just have to enable it. I believe it’s in the ‘Edit → Device Settings’…

You can move it via the gui in Lightburn. I use it to set focus.


Restarted Lightburn today and problem was gone. I did restart it several times after changing settings yesterday. Today it works. Thanks for the help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.