Z-Axis movement on K40 CO2 Laser

I use my K40 with MKS SBase and Grbl 1.1f. I have a motorized bed and try to understand the working priciple for moving the bed between the steps in cutting.
If I activate the Z-Axis, everything is fine (excepts the fact I can’t home Z-Axis) and the bed is moving correct when I use the arrows in the Tab Laser Head movement.
But if I activate to move the Bed during cutting, it goes into the wrong direction - downwards instead upwards. I can move the bed upwards with a negative value in the Z Offset, but if I enter anything under Z step it allows only positive values which moves the bed down and not up.

Is that wanted? If so, is there any workaround (inverting Z Axis works, but than the arrows for normal movement are wrong) or setting in Lightburn? Or could you add possibility for negative Z step per pass?


I see the same behavior. Flipped the Z axis in Lightburn settings so it works awesome when cutting. When I use the UP/DOWN arrows however, I have to use up for down and down for up. Any suggestions? Thanks!

@LightBurn Could you check If I might miss a setting somewhere? Or add/allow the negative values to Z step per pass field?

I got homing to work now, it was just switched off in the GRBL version I used.
But still it is needed to enter negative values into the layer pager in the field Z step per pass.
Any Chance to get that implemented @LightBurn?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.