Z axis moves but no command given


(Bob Waterfield) #1

I am running the latest version of LB, and a GRBL controller with 1.1F.

  1. I press home, Z,X, and Y Home.
  2. Select show position: Z=-10 X=Y-450 X=-450 this is the correct home position.
  3. Draw a simple 10x10mm square.
  4. Select Cut
  5. Z steps =0
  6. Material thickness =0
  7. Press start.
    Z Axis will move 10mm further away from home position. Cut will complete. X&Y return to home position. Z Never moves back to home.
    Select start again, Z will move another 10mm away, cut completes, X&Y return to home, Z Never moves back home.

I have tried this with relative Z moves on and off.
I know I am not the only one having this issue. I am wanting to cut some 3mm ply, and having the Z axis movement would give faster cleaner cuts.
I was really hoping this was goin to be fixed in this last release.


(Ray Kholodovsky) #2

I believe sending ? in console should get you a status report from the controller that includes current position.

Please do this at the time of step 2, and again after step 7. At step 2, verify that what LightBurn’s get position and this are reporting are the same thing.
Then after step 7, I am curious as to where it thinks it is.


(Bob Waterfield) #3

Before Step 2 Z=-10 this is correct 10mm away from the home switch.
After step 7 X=-20 Not correct.
I fail to find where it is getting a command to move 10mm away from start.
If I run the job again, it will move a further 10mm
Z will now show -30mm
Z never returns to home after a job start.


(Ray Kholodovsky) #4

X or Z ? Just have to make sure.

Can you provide screenshots of the entire LightBurn Window and the Cut Editor Window (no cell phone pics, please), and also the entire gCode file? You might have to use Dropbox or gDrive for the gCode file


(Bob Waterfield) #5

X or Z ? Just have to make sure.
Sorry Z.
X&Y are running correct.
Will post the requested screen grabs in a few.


(Robert Tate) #6

I had the same problem. I finally turned off z control in LB, but would like to be able to use the z control to control the depth of cut also. I will follow this thread and see what happens.


(Oz) #7

Bob - I believe this is the same bug that you reported in a different thread about Z control. It should be fixed in the next release.


(Bob Waterfield) #8

Oh that would be fantastic, driving me crazy.

Let me know, I’ll beta test it for you.


(Robert Tate) #9

I spent a few hours generating Gcode (save Gcode) with different settings in LB. and I think I see where it is doing it. Below is snippets of my output file that was saved (with my comments).

It looks like LB isn’t treating the Z axis mode the same mode as the X & Y. (mode = run from current position). In stead is it moving the Z back by how ever far down (in my case below, -40mm). Removing the line and it seems to run correctly (I didn’t turn on the laser during the tests for safety reasons) .

Start of my GCode file:

; start from current Position (60, 60, -40)
; Z axis enabled
; relative Z moves enabled
; reverse Z direction disabled
; 1mm per pass
; material thickness = 0.0 mm
;
;------------
; LightBurn 0.9.01
; GRBL device profile, current position
G00 G17 G40 G21 G54
G91
M4
; Cut @ 400 mm/min, 70% power
M8
G0X7Y9.29
; removed and it works OK!!! Why was it there??? G0Z40
; Z40 moves Z back to where the zero was.
; -40 is where I had it set to start.
;
G1Y6.98S700F400
G1X-1Y-1.4
G0X1Y-0.58
G1X-1Y-2
… end of file

I hope this helps. track this down.
For now I guess I can generate the gcode file and remove that line and then run the gcode file…


(Oz) #10

I believe I had already found this and removed it for the pending release - it’s been a week or two, so I’ll double check. LightBurn tracks the positions of all the axis during GCode generation to avoid accumulated rounding errors, and it needs to know where to start. I think I mistakenly told the software to move to the real Z position (absolute) instead of zero (relative), which is why that first move got generated.


(Robert Tate) #11

Thank you, I’m not crazy after all. :wink: I’ll keep my eyes open for the new release

I just noticed today that I had the 0.09.01 version and updated to .02 today. I’'ll have to keep my eyes open better.


(system) closed #12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.