Z axis offset not working

i think i have a problem with the Z axis offset not working, i am adding an offset in machine settings to work with an autofocus limit sensor the bed bed moves up and down twice to the start position of the sensor but then wont drop to the required offset, the controller is saying that the offset/ focus has been reached on the conrtroller screen ie 7mm, but the bed hasnt moved down 7mm is still on the stop point on the limit switch (1.5mm)

thanks
Alan

Since there has been no response, I will reference you to a couple of videos by Russ Sadler on dealing with autofocus. His stuff is RDWorks based and not so much Lightburn, but maybe they will give you something to go on.

I don’t have autofocus, so can’t be of much assistance.

Good luck

:smile_cat:

thanks Jack ive seen both those videos followed all the settings and still no luck i think the problem is with the eay the Z axis is configured as when we add a limit switch in the form of an autofocus pen we cant set any offset, or rather we can, the controller accepts it and shows its moved but the z axis doesnt move to the offset, the bed moves up and down with the controller z functions but not on the offset.

Alan

That’s about all I know about the Z stuff on these controllers. Seems like when I find information on them, most don’t find the autofocus useful. Many has said outright it was more trouble than it was worth… Maybe they work very well and the only thing I see is bad problems…

That doesn’t include the industrial type machines that just have an operator swapping parts between cuts… using autofocus… of course they paid for it. :crazy_face:

Good luck…

Might go over hunt around and see if any of these people that have videos do consulting. I’ve sent a couple of people to MW laser, but I just looked at the site and it didn’t look familiar… It cost them money, but I think they got them running even though it took lots of their time.

The Chinese controllers can be a nightmare to configure properly…

Good luck … keep us posted

:smile_cat: