Z home and Material thickness setup

Hello

We are setting up our machine for the first time and we are having issues the material thickness setup.

We are using a cohesion3d variant of the smoothie board with our z home set to positive and we have a working limit switch at our max position.

Currently, after homing we have the table z value set at 0mm which is our focus distance away from the lens. (everything with our homing seems to be working correctly. After homing our z it goes to z0 and when we press “Get Position” on the move tab it says z:0)

Now when we run a job with a material thickness of 3mm, I would expect the table to move down 3mm to compensate for the height of the material, but instead, it moves up 3mm so now I am out of focus and too close to the laser. The material thickness box does not allow for a negative number.

The z offset does allow for negative numbers but it returns to z zero after the cut so if we had a tall project on the table it would collide with the head.

Does anyone have any ideas on what we are doing wrong?

Our goal is to have the bed automatically go to the right height for whatever thickness material we are using based on our library.

C3D Forum will be better for this - there’s some topics I can dig up about setting this up.

With further poking around if I save the gcode I get:

; LightBurn 0.9.02
; Smoothieware device profile, absolute coords
G00 G17 G40 G21 G54
G90
M3
; Cut @ 50 mm/sec, 100% power
M106
G0X34.95Y548.96
G0Z5.9
G1Y568.19S1F3000
G1X63.8
G1Y548.96
G1X34.95
G1Y568.19
G1X63.8
G1Y548.96
G1X34.95
M107
G1S0
M5
G90
M2

In the cnc cam world this is configured in the post processor. If LightBurn is there a post processor for the “Smoothieware device profile” labeled in the header of my gcode? If the post processor could be configured to output a negative number for the line “G0Z5.9” my problem would be solved. Every thing else is working great with lightburn.

Who creates the “Smoothieware device profile” is that a lightburn thing or did someone in the smoothieware project create that?

Thanks

There is no user configurable post - It’s coded into LightBurn itself.

Everything in LightBurn assumes positive coordinates into the work area - DSP controllers don’t allow negative absolute coordinates, so some of this is because those were the systems LightBurn was originally authored for.

Having said that, there’s a toggle labeled ‘Reverse Z Direction’ in the upper right of the device settings window that should do what you need:

image

Ok, I knew about the reverse direction button but my brain didn’t want to go to the answer being down is positive, but it makes sense that that would work.

Well have to think about it as down increases the distance from zero rather then the direction the table is moving.

Thanks for the help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.