Z movement issues with RuiDa 6442

Problem #1:
Clicking either Move Z+ or Move Z- initiates a march to Z-extremes.
While I don’t yet have Z limit switches setup it does seem to be homing.
This is regardless of the state of Enable Z axis or Relative Z moves only.

  • Can I just get Z to move a certain increment per click of the arrow?
  • Or, can I disable Z movement from Lightburn direction pad?
  • And can I remove/disable the Focus Z from Lightburn?

Problem #2:
Can’t get Lightburn Z-/Z+ to move in the same directions as RuiDa Z-/Z+.
Invert Keypad Direction on RuiDa swaps directions but behavior remains.

  • Is there a toggle somewhere to get them moving the same direction?

Problem #3:
On a layer with multiple Number of Passes and a value for Z step per pass
there is no movement between the passes … Z does not move at all.

  • Given all the above, how do I get my Z step per pass working?

To people smarter than me, do any solutions appear obvious?

The “Distance” value in the move window controls how far the button click will go. What value do you have in yours? (and make sure the ‘Move from absolute zero’ button is NOT on)

If you don’t have Z limit switches, I can’t see how it could home (X & Y will, but Z won’t)

For Z moves, you need to enable Z in the device settings. (The buttons will work even with that off) That enables the sending of Z commands during the job. I recommend enabling Relative Z Moves as well. That tells the software to read the Z height when you start, and make all Z moves relative to that. Ruida doesn’t actually let me send relative moves during a job, so I have to know the starting height - You can enter it in the Material (mm) field, or I can read it when starting.

1 Like

Distance value is “10.00”. Changed to “1”.
Move from Absolute Zero is and was off.
Now it moves a set increment of 6mm.
I have some Z travel calibrating to do!

Z-movement buttons now work but Z needs calibrating.

Toggling Direction Polarity in Machine Settings corrects direction.
Relabeling the arrows on laser pad puts Lightburn and RuiDa in sync.
Focus button still causes an uninterrupted travel up toward the head.

Only remaining issue (other than calibration):
How do I get Focus Z to be disabled since I have no autofocus?

FYI, to be more clear about the limit switches …
I have limit switches for X & Y which are triggered at start-up.
I have Z+ limit switch that’s our of range currently (due to thick bed).
The Z is not tested in the initiation routine when the machine starts.
At start-up, the machine does it’s machine origin test on X and Y only.

OK, I used EagleWorks and turned off Auto Focus.
I also calibrated Z and now 10mm moves 10 mm.
Oz, this has been remarkably productive.

Thank you!!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.