Z table confusion

Greetings from New Zealand,

I have just installed a lightobjects z table into my k40 which has a c3d laserboard with smoothie firmware.

I have added an end stop at the top of the z table at the focal distance of the beam. If I press the up button in LightBurn the table goes up and the down button moves it down.

If I navigate using the laserboard panel to home all axes the laserboard successfully moves the table up until it hits the switch and then moves down a bit and back up as expected. All good so far.

Reading the coordinates at this homed position says z is 50. Zero is at the bottom. It is configured in the config file on the SD card to home_to_max and the end stop is connected to the z max connector.

Using M119 to test the switch reads zero for not pressed and 1 for pressed.

The problem is when I start a job in LightBurn the table moves all the way to the bottom to where z equals zero plus the material thickness. The table moves down between passes instead of up when I have a positive z step per pass set in LightBurn.

I have relative z moves only checked in the device settings which I thought would allow the job to start at whatever the current z position is but the table moves at the start of a job nevertheless.

I have tried checking reverse z direction but then the up button moves the table down and the down button moves it up.

I seemed to have missed something.

Kind regards,


Have you tried swapping the plug to the Z-min pins and change the config to home_to_min? Seems that the highest position on the Z table would be more of a min over max, right?

That’s how I had it originally, it tries to home downward that way and never hits the stop because there isn’t one at the bottom. Although perhaps I could then swap the wires on one of the motor coils. But isn’t that just equivalent of two 180° swaps and I’m back where I started?
I like it homing to the top - that makes sense to me. How do others have it?

I have found a possible clue. For some reason, there is an extra z movement being added to the gcode based on the current position of the z table and the thickness of the material. Even when I have “relative z moves only” checked in device settings. My understanding was this would ignore the material thickness and start where it currently is but this seems not to be the case. If I modify the material thickness to 1mm more, the extra z movement command changes to one less. Here are the first lines of code produced from lightburn:

; LightBurn 0.9.02
; Smoothieware device profile, current position
G00 G17 G40 G21 G54
; Cut @ 10 mm/sec, 100% power

The culprit is the “G0Z-34”. My z table was at position 40mm and the material was 6mm thick so it moved 34mm down. Why does this appear in the gcode in relative z mode?

Then later on there is another command to move the table “G0Z-1”. This moves down. If I choose “reverse z direction” then this movement becomes positive and the table moves up between passes as expected but then the down button on lightburn goes up and the up button goes down. Worse, the table moves up 34mm at the start of the job and grinds the belt at the top.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.