
HOW TO
SPEED UP JOBS

By Billie Ruben - LightBurn Software



•Many ways to speed up production, what applies depends 
on goals.

•We will start with some simpler ones, you may know these 
already, and get more complex.

•Whenever you see the book symbol, I have included links to 
relevant documentation, in show notes of the presentation.

• We will be moving quickly, so it may be tricky to follow along 
in the software, 

• I have uploaded this slide deck so you can reference it at 
your own pace. 

• Show how to find on Forum

● Australian
● Maker of many kinds
● Makerspace & 

Community Facilitator
● Content Team at 

LightBurn Software:
○ Documentation
○ YouTube Videos
○ User Experience
○ Graphic Design

HELLO! I’M BILLIE RUBEN

Slides available: 
LightBurn Forum > 
Resources or:



● Costs are rising
● But the odds are in 

your favor 

WHY OPTIMIZE?

● Material getting more expensive but congrats! 
● Laser remains one of the best ways to make money as 

a maker/ small to medium business. 
● How do I know? Australia has highest minimum wage 

on earth & extremely high shipping - 
unavoidable costs, yet every 3rd stall at craft markets is 
a laser business.

●
● Many ways to speed up production, what applies 

depends on goals.
● We will start with some simpler ones, you may know 

these already, and get more complex.
● Whenever you see the book symbol, I have included 

links to relevant documentation, in show notes of the 
presentation.



MAXIMIZE 
SPEED?

• Many folk think to make my jobs quicker, I just need to 
speed up.

• It’s intuitive, like driving in a car - minimize travel distance, 
and go as fast as you can, right?

• But is it always faster? No. Because a laser needs to turn back to 
make the next line it has to slow to a stop, then accelerate again as it moves 
along the next line. As you increase the speed, this distance gets longer, 
and this can add time.

• Depends on your settings. Always check preview. 



● Always Preview Job.
● Black = Cutting/Engraving = Laser ON
● Red = Travel/Rapid Moves = Laser OFF

(Preview > Show traversal moves)
● Note the time estimates

PREVIEW JOBS

• Always Preview your jobs, both for seeing how long it will 
take, but also to spot any accidents before you cut into your 
material. 

• Rapid and Cut move distances are listed below preview. 

• If you don’t see red, click on “Show Traversal Moves”

More Info: 

• Preview Window (includes videos): 
https://docs.lightburnsoftware.com/latest/Reference/Preview/#



If Preview times inaccurate: 
● Edit>Device Settings> Additional Settings 

○ “Read from Controller” or: 
○ manually adjust “Simulation Settings”

PREVIEW ACCURACY

• “Find my laser” when adding a machine pulls device 
settings from machine. 

• If you find the preview estimates are very different to your 
real-life job time, you can adjust them.

• Change Simulation Settings via Edit>Device Settings> 
Additional Settings 

• Changing Sim Settings does NOT change anything on your 
controller or your job settings. Just the preview. 

More Info

• Video: Get Accurate Job Times in LightBurn:
https://www.youtube.com/watch?v=s1jCqB233N0

• Device Settings:
https://docs.lightburnsoftware.com/latest/Reference/DeviceSettings/Addition
alSettings/

https://www.youtube.com/watch?v=s1jCqB233N0
https://docs.lightburnsoftware.com/latest/Reference/DeviceSettings/AdditionalSettings/
https://docs.lightburnsoftware.com/latest/Reference/DeviceSettings/AdditionalSettings/


● Minimize how far the laser has to move
● Both of laser ON & OFF
● Lots of ways to do this

MINIMIZE DISTANCE

● Generally the less red and black we see in the preview 
the quicker the job will be.



Line Layers travel far less,
follow the contour/perimeter

Image, Fill, or Offset Layers 
use many lines to ‘color in’ area

AVOID RASTER ENGRAVINGS

Image, Fill, or Offset Layers 
use many lines to ‘color in’ area

• Two types of ways a laser can move, 

• either by tracing along vector lines, 

• or by filling in an area by ‘scanning’ back and forth. 

• Scanning is used for engraving images and filling closed 
vector shapes.

• Scanning takes far more time because it has to move much 
farther. 

Further reading:

• Layer modes: 
https://docs.lightburnsoftware.com/latest/Explainers/LayerModes/

• Image vs Vector: 
https://docs.lightburnsoftware.com/latest/Explainers/ImagesVsVectors/

• Closed vs Open Shapes: 
https://docs.lightburnsoftware.com/latest/Explainers/OpenClosedShapes/

•

https://docs.lightburnsoftware.com/latest/Explainers/LayerModes/
https://docs.lightburnsoftware.com/latest/Explainers/ImagesVsVectors/
https://docs.lightburnsoftware.com/latest/Explainers/OpenClosedShapes/




ADJUST THE DESIGN

Engrave with lines, not fills: 

●
You can score a line. A Lot of folk think of line 
operations as a ‘cut’, but they don’t have to be. 
With lower power or higher speed, you can avoid 
cutting all the way through, and instead just score a 
line.

If you design with this in mind you can DRASTICALLY 
reduce the time of your jobs. 

Depends on design. Sometimes you need a fill, e.g if 
you’re removing an area of material, but often you 
don’t. Often an outline will do. 

Further reading:



• Layer modes: 
https://docs.lightburnsoftware.com/latest/Explainers/LayerModes/

• Image vs Vector: 
https://docs.lightburnsoftware.com/latest/Explainers/ImagesVsVectors/

• Closed vs Open Shapes: 
https://docs.lightburnsoftware.com/latest/Explainers/OpenClosedShapes/

https://docs.lightburnsoftware.com/latest/Explainers/LayerModes/
https://docs.lightburnsoftware.com/latest/Explainers/ImagesVsVectors/
https://docs.lightburnsoftware.com/latest/Explainers/OpenClosedShapes/


● Line Mode isn’t cut 
mode

● Difference between a 
cut line and a score 
(engrave/ mark) line 
is your settings 

● Lower power and 
increase speed to 
score.

CUT VS SCORE



INCREASE LINE THICKNESS
Cut Settings Editor - Z Offset   (Out)

• Increase line thickness by setting Z-Offset outwards/away 
from material. 

• Different lenses = different results, test. 



SPEED UP TEXT

• This also applies to Text. 

• Engraving a word takes a lot longer than outlining it. 

• And outlining a word takes longer than a single line font. 



SHX = format that allows open shapes

1. Download SHX fonts (forum)
2. Add to a folder on your computer
3. LightBurn > Preferences/Settings
4. Set SHX Font Path (to your folder)
5. Apply like normal font
6. Can filter by right-clicking font list

SINGLE-LINE FONTS

• Single line fonts generally have a different format to 
normal fonts that word or photoshop would use. 

• This is to support ‘open’ geometry (not enclosed 
shapes) 

• Currently we support SHX.

• SHX Fonts installed differently, 
https://docs.lightburnsoftware.com/latest/Reference/Text/#shx-fonts

• These can be downloaded online, there’s a pack a 
user has provided on our forum. 

Save Favorite fonts by selecting a font > right clicking the font 
selector > add to favorites. 

More Info

• SHX Fonts:
https://docs.lightburnsoftware.com/latest/Reference/Text/#shx-fonts

• Some SHX Fonts to get you started. 
https://forum.lightburnsoftware.com/t/shx-font-collection/25298

https://docs.lightburnsoftware.com/latest/Reference/Text/#shx-fonts
https://docs.lightburnsoftware.com/latest/Reference/Text/#shx-fonts
https://forum.lightburnsoftware.com/t/shx-font-collection/25298


● Edit> Delete Duplicates (just for one job) 
● For all Jobs: 

○ Laser Window > Optimization Settings > 
Remove Overlapping Lines

○ Distance = how close lines need to be, 
in order to be considered ‘duplicate’

○ Will even remove short lines that are 
entirely covered by another line

REMOVE OVERLAPPING LINES

● Tells the Cut Planner to remove lines that are 
overlapping, and would cause the laser to cut in the 
same place twice.

● The Distance field to the right of the switch controls 
how close two lines need to be in order for the Cut 
Planner to remove one of them when sending the job 
to your laser.

More Info

• Remove Overlapping Lines Documentation
https://docs.lightburnsoftware.com/latest/Reference/OptimizationSettings/#r
emove-overlapping-lines

• Remove Overlapping Lines Video 
https://www.youtube.com/shorts/tHTnb6MURdU?feature=share

• Grid Array
https://docs.lightburnsoftware.com/latest/Reference/GridArray/

https://docs.lightburnsoftware.com/latest/Reference/OptimizationSettings/#remove-overlapping-lines
https://docs.lightburnsoftware.com/latest/Reference/OptimizationSettings/#remove-overlapping-lines
https://www.youtube.com/shorts/tHTnb6MURdU?feature=share
https://docs.lightburnsoftware.com/latest/Reference/GridArray/


● Passes = how many times 
the laser passes over the 
same layer

● Reduce passes by lowering 
speed & increasing power

REDUCE PASSES

Passes: 

• Passes: 
https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/Line
Mode/#number-of-passes

https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/LineMode/#number-of-passes
https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/LineMode/#number-of-passes


● Images (photos, greyscale graphics) 
● Fill areas with flat color
● Remove material from areas

WHEN ‘SCANNING’ IS NECESSARY:



● Run more than one job at a time
● Stack multiple objects side-by-side
● Align, Distribute, Docking helpful
● Put tall objects on side

LAYOUT IS CRITICAL

● Layout is critical

○ Layout of jobs (particularly when engraving) 
tall objects, put on side. 

○ Duplicate objects, fit horizontally. Multiple 
objects- stack side-by-side

○ Reduce the red in the preview. halving 
frame-like jobs and fill groups together (e.g. 
clock face)

○ Alignment, Distr



● Fill (large areas) 
● Fill Grouping (all, groups, individual) 
● Flood Fill

● Offset Fill
● Manually ‘broken’ fill

FILL METHODS

These options control which shapes are engraved at the 
same time by the laser. If you run your laser fast, or your 
laser accelerates slowly, it is often most efficient to scan 
things all at once, so the laser spends most of its time moving 
at the speed you've chosen, and less time changing direction. 
If you are engraving slowly, your laser accelerates fast, or the 
design contains a lot of blank space, it can be more efficient 
to fill clusters of close shapes, or to fill the shapes one by 
one.

Fill all shapes at once: The default, this setting means that 
everything on this layer will be filled at the same time, 
sweeping back and forth across the whole job. If you are 
running the laser fast (300 mm/sec or more) this is usually 
the most efficient option, with some exceptions.

Fill groups together: This setting will fill all shapes in a group 
at the same time.



Fill shapes individually: This setting fills all shapes one by one.

Advanced Settings:

Flood Fill: calculates an engraving path that attempts to reduce or 
eliminate travel moves across blank space. It's useful for engraving 
things like large, empty rectangles, where the blank area in the 
middle would consume most of the time spent.

More Info 

• https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/FillMode/

https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/FillMode/
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• Found in Cut Settings for Fill/Image Modes

• Turns laser around at each end, drastically saving travel 
moves 

• Reasons to have it off: 

• Your laser has slop/starts and ends don’t line up. 

• Unlikely given your machines, 

• but if you do encounter this you can compensate with 
Scanning Offset Adjustment 

More Info: 

• Bi-directional Fill Docs: 
https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/Imag
eMode/#bi-directional-scanning

• Scanning Offset Adjustment: 
https://docs.lightburnsoftware.com/latest/Guides/ScanningOffsetAdjustment/

https://docs.google.com/file/d/1TiktKyCyd2KYRnuWspJklGvuATpSgZ14/preview
https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/ImageMode/#bi-directional-scanning
https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/ImageMode/#bi-directional-scanning
https://docs.lightburnsoftware.com/latest/Guides/ScanningOffsetAdjustment/


● DPI and Line Interval are linked
● Higher DPI not always better 

quality
● When lines overlap:

○ Images too dark 
○ Details muddy 
○ Engravings textured

LINE INTERVAL

• Higher DPI isn’t better when it causes your scan lines to 
overlap. This will make muddy designs. 

• CO2 actually has rather large beam size compared to 
Diode or MOPA that Tong spoke about yesterday. 

• Ideally you want each line to juuust touch. Use magnifying 
jewelers loop or USB Microscope to assess. 

• Interval or materials test generator tools. 

More Info 

• Fill Mode 
https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/FillMo
de/

• Materials Test 
https://docs.lightburnsoftware.com/latest/Reference/MaterialTest/ 

• Line Interval Test 
https://docs.lightburnsoftware.com/latest/Reference/IntervalTest/

https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/FillMode/
https://docs.lightburnsoftware.com/latest/Reference/CutSettingsEditor/FillMode/
https://docs.lightburnsoftware.com/latest/Reference/MaterialTest/
https://docs.lightburnsoftware.com/latest/Reference/IntervalTest/


● Minimize scan lines by 
increasing Line Interval 
(Layer Settings)

● Defocus increases line 
width, allows you 
to increase line interval 
further

● Defocus via Z Offset (Layer 
Settings)

LINE INTERVAL

• Higher Line interval = larger gap between lines = fewer 
lines = quicker 

• Beam has a ‘waist’ smallest at focal point 

• Either side of this the beam gets thicker

• We can use this to make thicker lines and lower out interval 
even more. 



● V. High Line Interval 
= interesting effects

● Combine with 
Scan Angle for 
slanted lines

● SUPER quick

HACKING LINE INTERVAL

https://youtu.be/KrAQY9wFv2c?si=CbtAy8wpbHl8L65X 

https://youtu.be/KrAQY9wFv2c?si=CbtAy8wpbHl8L65X


● Settings to Library
● Designs to Art Library 
● Cut-out pieces to tool layers 

SAVE FOR FUTURE



● When it costs you no extra time: 
○ Optimization Settings 
○ Reusing known settings

● When the time it takes you to set up is 
less than the time it saves in the job. E.g.
○ When doing many similar jobs 
○ When you are running large engraves

WHEN TO OPTIMIZE?

● When is it right to spend time optimizing? 



● Tooltips 
● Documentation. So much documentation. 
● Loads of videos too
● Hover over tool 

& hit F1 (fn+F1 on mac) 

HELP



▰ www.LightBurnSoftware.com
▰ Support@LightBurnSoftware.com
▰ Docs.LightBurnSoftware.com
▰ Forum.LightBurnSoftware.com
▰ YouTube.com/@lightburnsoftware7189l




