0.9.13 issues with inch/mm setting

I just updated to 0.9.13 and had a problem with mm and inch setting. When I set it to inches with the button just to the right of “rotate” box it will not go back to mm. If the small box reads “mm” and I open the “cut settings editor” box, the indicator goes back to “in”. Also, after finishing a cut the laser goes to the front left. If I hit “home” it goes to the rear left as it did in the past after finishing a job.
Even when I shut down and restart it goes to inches and unable to change to mm anymore.

Please create a new topic if your issue has nothing to do with the topic you’re responding to - it makes it a lot easier to keep track of responses this way.

I don’t have the issue that you do with the mm/in button, and the cut settings editor is not related to that control in any way, so the interaction you’re describing there is a bit bizarre. I would say try restarting the software just to make sure there’s not some temporary glitch somewhere, but even that is a wild guess.

For the finish position, you can change that here in Edit > Device Settings:


The above value is the default.

I thought because it was related to the update causing problems. I’ll start another topic and include some screen shots

I moved the topic - that’s fine, you can keep replying here. Updates almost always break something for someone, and where there are multiple issues it’s easier for me to keep track of them if they are distinct topics on their own, not just “the update broke” - no harm, just letting you know why I moved it.

ok thanks, basically I am unable to get mm, even with opening older projects it is all inches including support height and material height

That by itself isn’t unexpected - the mm/inch setting is global, not per project, but it’s very strange that you can’t change it. What kind of computer / operating system are you using?

macbook/Catalina/10.15.4 Safari ver 13.1

So it looks like the issue is just that button - the little mm/inch indicator is backwards for some reason on the Mac, but everything else is correct. I’m looking into it, but basically when you start the software it’s correct, but the first time you click it, it goes backwards.

When I just opened it again it started in inches and still will not switch. I notice when the button is pressed that the numbers around work area change (outside the grid). Anyway I’ll leave it with you. Thanks.

Like I said, it’s actually just the button that’s wrong. I have this fixed and we’ll be posting a release shortly. I suspect if you go into the settings and change it there it will work as expected.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.