0.9.20 Update scale way out of proportion

After updating this morning and doing a bed capture the scale of the project i opened is way off by about an inch and half. Anyone seeing issues with the scale on X and or Y axises now?

I was wrong there is a major scaling issue now in this new version. Even after loading my saved camera calibration and then manually adjusting my design to fit within the bounds of the material (mirror) it burned even more oversized than defined in the display and interface view of Light burn. Just wasted a 6 dollar mirror because of it. Rolling back to version 0.9.19 I guess till this is resolved.

There is no scaling issue I’m aware of. Can you show screen shots, or something else? Is this only the camera that’s scaled, or the actual project in LightBurn?

first image is the new version I just loaded my project that I had saved. Look at the orientation of the T1 layer and the 01 layer. When I burned it it was way off. Its not a camera issue and alignment because I ran the framing like 6 times before burning. When I burned it I got what’s shown in image 2. I then reverted to version .19 and reloaded my camera calibration and loaded the same project without any other changes other than aligning it and it burned perfectly.

If you zoom in on that first image which I took while it was doing the burn you can see where the T1 and 01 layers are oriented and then if you look to live image in image one on the right you can see how far down its actually burning. Once I reinstalled version .19 and did the exact same thing I did the first time it burned correctly as expected.


Also I notice a few other people post about a scaling issue after the update. When you isntall a new update do you have to re-do all the camera calibration again? Is loading a saved calibration all that would be required?

The calibration data hasn’t changed - it’s the camera code itself not properly applying the lens calibration to the image.

I would agree with that I guess, but why after running the framing 6 times to ensure it was within the bounds of the material (mirror) it still burned lower than expected. I only use the camera to get a rough reference of where to place the design and then I manually run framing and the move it in whatever direction is needed to I get it where it needs to be. Once I went back to the previous version loaded the project and did the framing and moved it around exactly like I did the first time it burned exactly where I expected it to.

Here is an image I took right after reinstalling the .19 version and loading the project, if you look at the metal square I have mounted there that I use for alignment you can see in image one it has a wierd bulge in the center and the old version does not. So I would say you are correct that the calibration profiles are at the very least not correct.

Have you tried the update I posted in the other thread?

Pretty sure you are right, after loading the project into both version without changing anything you can clearly see the the T1 in the .19 version compared to the picture frame below it is overlapping the black part of the frame and in the image of version .20 the same project loaded and unchanged is well inside the white area of the mirror inside the frame.

This is fixed, and now pushed / released. You should see an update to 0.9.20 if you check for updates.

Ok thanks, will update and post if there are any issues.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.